summaryrefslogtreecommitdiffstats
path: root/binaryurp/CppunitTest_binaryurp_test-unmarshal.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /binaryurp/CppunitTest_binaryurp_test-unmarshal.mk
parentInitial commit. (diff)
downloadlibreoffice-1ad18e38974bb28c3d98d0be8f7d8c18fc56de29.tar.xz
libreoffice-1ad18e38974bb28c3d98d0be8f7d8c18fc56de29.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'binaryurp/CppunitTest_binaryurp_test-unmarshal.mk')
-rw-r--r--binaryurp/CppunitTest_binaryurp_test-unmarshal.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/binaryurp/CppunitTest_binaryurp_test-unmarshal.mk b/binaryurp/CppunitTest_binaryurp_test-unmarshal.mk
new file mode 100644
index 000000000..11c70f5b9
--- /dev/null
+++ b/binaryurp/CppunitTest_binaryurp_test-unmarshal.mk
@@ -0,0 +1,33 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,binaryurp_test-unmarshal))
+
+$(eval $(call gb_CppunitTest_use_external,binaryurp_test-unmarshal,boost_headers))
+
+$(eval $(call gb_CppunitTest_use_libraries,binaryurp_test-unmarshal,\
+ cppu \
+ cppuhelper \
+ sal \
+ salhelper \
+))
+
+$(eval $(call gb_CppunitTest_use_library_objects,binaryurp_test-unmarshal,\
+ binaryurp \
+))
+
+$(eval $(call gb_CppunitTest_use_api,binaryurp_test-unmarshal,\
+ udkapi \
+))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,binaryurp_test-unmarshal,\
+ binaryurp/qa/test-unmarshal \
+))
+
+# vim: set noet sw=4 ts=4: