summaryrefslogtreecommitdiffstats
path: root/cli_ure/Library_cli_cppuhelper_native.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /cli_ure/Library_cli_cppuhelper_native.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'cli_ure/Library_cli_cppuhelper_native.mk')
-rw-r--r--cli_ure/Library_cli_cppuhelper_native.mk51
1 files changed, 51 insertions, 0 deletions
diff --git a/cli_ure/Library_cli_cppuhelper_native.mk b/cli_ure/Library_cli_cppuhelper_native.mk
new file mode 100644
index 000000000..bb230fb01
--- /dev/null
+++ b/cli_ure/Library_cli_cppuhelper_native.mk
@@ -0,0 +1,51 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+include $(SRCDIR)/cli_ure/version/version.txt
+
+$(eval $(call gb_Library_Assembly,cli_cppuhelper))
+
+$(eval $(call gb_Library_add_ldflags,cli_cppuhelper,\
+ -ignore:4248 \
+ -keyfile:$(SRCDIR)/cli_ure/source/cliuno.snk \
+))
+
+$(eval $(call gb_Library_add_ldflags,cli_cppuhelper,\
+ -delayload:$(call gb_Library_get_filename,cppuhelper) \
+ -delayload:$(call gb_Library_get_filename,cppu) \
+ -delayload:$(call gb_Library_get_filename,sal) \
+))
+
+$(eval $(call gb_Library_use_internal_bootstrap_api,cli_cppuhelper,\
+ udkapi \
+))
+
+$(eval $(call gb_Library_use_libraries,cli_cppuhelper,\
+ cppu \
+ cppuhelper \
+ sal \
+))
+
+$(eval $(call gb_Library_use_system_win32_libs,cli_cppuhelper,\
+ advapi32 \
+ delayimp \
+ mscoree \
+ msvcmrt \
+))
+
+$(eval $(call gb_Library_add_cxxclrobjects,cli_cppuhelper,\
+ cli_ure/source/native/native_bootstrap \
+ cli_ure/source/native/path \
+))
+
+$(eval $(call gb_Library_add_generated_cxxclrobjects,cli_cppuhelper,\
+ CustomTarget/cli_ure/source/native/assembly \
+))
+
+# vim: set noet sw=4 ts=4: