summaryrefslogtreecommitdiffstats
path: root/config_host/README
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /config_host/README
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'config_host/README')
-rw-r--r--config_host/README25
1 files changed, 25 insertions, 0 deletions
diff --git a/config_host/README b/config_host/README
new file mode 100644
index 000000000..5dd2d5263
--- /dev/null
+++ b/config_host/README
@@ -0,0 +1,25 @@
+These are configuration files for various features as detected by configure.
+
+Include only those files you need (in order to reduce rebuilds when a setting changes).
+
+Settings here are only C/C++ #define directives, so they apply only to C/C++ source,
+not to Makefiles.
+
+
+
+Adding a new setting:
+=====================
+
+- do AC_DEFINE(HAVE_FOO) in configure.ac when a setting should be set
+- choose the proper config_host/config_XXX.h file to use
+ - if it is a global setting (such as availability of a compiler feature),
+ use config_host/config_global.h
+ - otherwise check if there is a matching config_host/config_XXX.h file
+ - if none matches, add a new one:
+ - add config_host/config_XXX.h.in here, with just #ifndef include guard
+ - add AC_CONFIG_HEADERS([config_host/config_XXX.h]) next to the others
+ in configure.ac
+- add #define HAVE_FOO 0 to the config_host/config_XXX.h , possibly with a comment
+ (do not use #undef HAVE_FOO, unless the setting has more values than on/off)
+- add #include <config_XXX.h> before any #if HAVE_FOO in a source file
+- make sure you use #if HAVE_FOO for on/off settings, do not use #ifdef