summaryrefslogtreecommitdiffstats
path: root/cppcanvas/CppunitTest_cppcanvas_test.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /cppcanvas/CppunitTest_cppcanvas_test.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'cppcanvas/CppunitTest_cppcanvas_test.mk')
-rw-r--r--cppcanvas/CppunitTest_cppcanvas_test.mk55
1 files changed, 55 insertions, 0 deletions
diff --git a/cppcanvas/CppunitTest_cppcanvas_test.mk b/cppcanvas/CppunitTest_cppcanvas_test.mk
new file mode 100644
index 000000000..e6e7a39d3
--- /dev/null
+++ b/cppcanvas/CppunitTest_cppcanvas_test.mk
@@ -0,0 +1,55 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#*************************************************************************
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#*************************************************************************
+
+$(eval $(call gb_CppunitTest_CppunitTest,cppcanvas_test))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,cppcanvas_test, \
+ cppcanvas/qa/unit/test \
+))
+
+$(eval $(call gb_CppunitTest_use_external,cppcanvas_test,boost_headers))
+
+$(eval $(call gb_CppunitTest_use_libraries,cppcanvas_test, \
+ cppcanvas \
+ basegfx \
+ canvastools \
+ comphelper \
+ cppu \
+ cppuhelper \
+ i18nlangtag \
+ sal \
+ svt \
+ test \
+ tl \
+ unotest \
+ vcl \
+))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,cppcanvas_test))
+
+$(eval $(call gb_CppunitTest_use_ure,cppcanvas_test))
+$(eval $(call gb_CppunitTest_use_vcl,cppcanvas_test))
+
+$(eval $(call gb_CppunitTest_use_components,cppcanvas_test,\
+ canvas/source/cairo/cairocanvas \
+ canvas/source/factory/canvasfactory \
+ configmgr/source/configmgr \
+ i18npool/util/i18npool \
+ linguistic/source/lng \
+ package/util/package2 \
+ sax/source/expatwrap/expwrap \
+ ucb/source/core/ucb1 \
+ unoxml/source/service/unoxml \
+))
+
+$(eval $(call gb_CppunitTest_use_configuration,cppcanvas_test))
+
+# vim: set noet sw=4 ts=4: