summaryrefslogtreecommitdiffstats
path: root/cppuhelper/InternalUnoApi_cppuhelper.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /cppuhelper/InternalUnoApi_cppuhelper.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--cppuhelper/InternalUnoApi_cppuhelper.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/cppuhelper/InternalUnoApi_cppuhelper.mk b/cppuhelper/InternalUnoApi_cppuhelper.mk
new file mode 100644
index 000000000..d2849b0a3
--- /dev/null
+++ b/cppuhelper/InternalUnoApi_cppuhelper.mk
@@ -0,0 +1,20 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_InternalUnoApi_InternalUnoApi,cppuhelper,cppuhelper/unotypes))
+
+$(eval $(call gb_InternalUnoApi_use_api,cppuhelper,\
+ udkapi \
+))
+
+$(eval $(call gb_InternalUnoApi_add_idlfiles,cppuhelper,cppuhelper/detail,\
+ XExceptionThrower \
+))
+
+# vim:set noet sw=4 ts=4: