summaryrefslogtreecommitdiffstats
path: root/desktop/Executable_unopkg.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /desktop/Executable_unopkg.mk
parentInitial commit. (diff)
downloadlibreoffice-upstream.tar.xz
libreoffice-upstream.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'desktop/Executable_unopkg.mk')
-rw-r--r--desktop/Executable_unopkg.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/desktop/Executable_unopkg.mk b/desktop/Executable_unopkg.mk
new file mode 100644
index 000000000..28a753a57
--- /dev/null
+++ b/desktop/Executable_unopkg.mk
@@ -0,0 +1,29 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,unopkg))
+
+$(eval $(call gb_Executable_set_targettype_gui,unopkg,YES))
+
+$(eval $(call gb_Executable_use_static_libraries,unopkg,\
+ ooopathutils \
+ winloader \
+))
+
+$(eval $(call gb_Executable_use_system_win32_libs,unopkg,\
+ shell32 \
+))
+
+$(eval $(call gb_Executable_add_exception_objects,unopkg,\
+ desktop/win32/source/officeloader/unopkg_exe \
+))
+
+$(eval $(call gb_Executable_add_default_nativeres,unopkg))
+
+# vim: set ts=4 sw=4 et: