summaryrefslogtreecommitdiffstats
path: root/desktop/WinResTarget_scalc.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /desktop/WinResTarget_scalc.mk
parentInitial commit. (diff)
downloadlibreoffice-upstream.tar.xz
libreoffice-upstream.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--desktop/WinResTarget_scalc.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/desktop/WinResTarget_scalc.mk b/desktop/WinResTarget_scalc.mk
new file mode 100644
index 000000000..7060dcb77
--- /dev/null
+++ b/desktop/WinResTarget_scalc.mk
@@ -0,0 +1,27 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_WinResTarget_WinResTarget,scalc/launcher))
+
+$(eval $(call gb_WinResTarget_set_include,scalc/launcher,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/sysui/desktop \
+))
+
+$(eval $(call gb_WinResTarget_add_defs,scalc/launcher,\
+ -DRES_APP_ICON=icons/calc_app.ico \
+))
+
+$(eval $(call gb_WinResTarget_add_dependencies,scalc/launcher,\
+ sysui/desktop/icons/calc_app.ico \
+))
+
+$(eval $(call gb_WinResTarget_set_rcfile,scalc/launcher,desktop/win32/source/applauncher/launcher))
+
+# vim: set ts=4 sw=4 et: