summaryrefslogtreecommitdiffstats
path: root/libreofficekit/Library_libreofficekitgtk.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /libreofficekit/Library_libreofficekitgtk.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'libreofficekit/Library_libreofficekitgtk.mk')
-rw-r--r--libreofficekit/Library_libreofficekitgtk.mk42
1 files changed, 42 insertions, 0 deletions
diff --git a/libreofficekit/Library_libreofficekitgtk.mk b/libreofficekit/Library_libreofficekitgtk.mk
new file mode 100644
index 000000000..842bce6ac
--- /dev/null
+++ b/libreofficekit/Library_libreofficekitgtk.mk
@@ -0,0 +1,42 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,libreofficekitgtk))
+
+$(eval $(call gb_Library_use_sdk_api,libreofficekitgtk))
+
+$(eval $(call gb_Library_add_exception_objects,libreofficekitgtk,\
+ libreofficekit/source/gtk/lokdocview \
+ libreofficekit/source/gtk/tilebuffer \
+))
+
+$(eval $(call gb_Library_use_externals,libreofficekitgtk,\
+ boost_headers \
+))
+
+$(eval $(call gb_Library_set_include,libreofficekitgtk,\
+ $$(INCLUDE) \
+ $$(GTK3_CFLAGS) \
+))
+
+$(eval $(call gb_Library_add_libs,libreofficekitgtk,\
+ $(GTK3_LIBS) \
+))
+
+$(eval $(call gb_Library_add_defs,libreofficekitgtk,\
+ -DLOK_PATH="\"$(LIBDIR)/libreoffice/$(LIBO_LIB_FOLDER)\"" \
+))
+
+ifeq ($(OS),$(filter LINUX %BSD SOLARIS, $(OS)))
+$(eval $(call gb_Library_add_libs,libreofficekitgtk,\
+ $(DLOPEN_LIBS) -lm \
+))
+endif
+
+# vim: set noet sw=4 ts=4: