summaryrefslogtreecommitdiffstats
path: root/odk/CustomTarget_build-examples.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /odk/CustomTarget_build-examples.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'odk/CustomTarget_build-examples.mk')
-rw-r--r--odk/CustomTarget_build-examples.mk34
1 files changed, 34 insertions, 0 deletions
diff --git a/odk/CustomTarget_build-examples.mk b/odk/CustomTarget_build-examples.mk
new file mode 100644
index 000000000..de3e9653f
--- /dev/null
+++ b/odk/CustomTarget_build-examples.mk
@@ -0,0 +1,34 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t; fill-column: 100 -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+my_example_dirs = \
+ CLI/CSharp/Spreadsheet \
+ CLI/VB.NET/WriterDemo \
+ DevelopersGuide/BasicAndDialogs/ToolkitControls \
+ DevelopersGuide/Components/Addons/ProtocolHandlerAddon_cpp \
+ DevelopersGuide/Components/CppComponent \
+ DevelopersGuide/Database/DriverSkeleton \
+ DevelopersGuide/Extensions/DialogWithHelp \
+ DevelopersGuide/OfficeDev/FilterDevelopment/FlatXmlFilter_cpp \
+ DevelopersGuide/ProfUNO/CppBinding \
+ DevelopersGuide/ProfUNO/SimpleBootstrap_cpp \
+ OLE/activex \
+ cpp/DocumentLoader \
+ cpp/complextoolbarcontrols \
+ cpp/counter \
+ cpp/remoteclient \
+ python/toolpanel \
+
+
+# cpp/custompanel \
+
+
+$(eval $(call odk_build-examples_test,odk/build-examples,$(my_example_dirs)))
+
+# vim: set noet sw=4 ts=4: