summaryrefslogtreecommitdiffstats
path: root/odk/CustomTarget_html.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /odk/CustomTarget_html.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'odk/CustomTarget_html.mk')
-rw-r--r--odk/CustomTarget_html.mk32
1 files changed, 32 insertions, 0 deletions
diff --git a/odk/CustomTarget_html.mk b/odk/CustomTarget_html.mk
new file mode 100644
index 000000000..750b7777b
--- /dev/null
+++ b/odk/CustomTarget_html.mk
@@ -0,0 +1,32 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,odk/html))
+
+$(eval $(call gb_CustomTarget_register_targets,odk/html,\
+ docs/install.html \
+ docs/tools.html \
+ examples/DevelopersGuide/examples.html \
+ examples/examples.html \
+ index.html \
+))
+
+$(call gb_CustomTarget_get_workdir,odk/html)/%.html : $(SRCDIR)/odk/%.html
+ $(call gb_Output_announce,$*.html,$(true),SED,1)
+ $(call gb_Trace_StartRange,$*.html,SED)
+ sed -e 's|%PRODUCT_RELEASE%|$(PRODUCTVERSION)|g' \
+ -e 's|%DOXYGEN_PREFIX0%|$(if $(DOXYGEN),.,https://api.libreoffice.org)|g' \
+ -e 's|%DOXYGEN_PREFIX1%|$(if $(DOXYGEN),..,https://api.libreoffice.org)|g' \
+ -e 's|%DOXYGEN_PREFIX2%|$(if $(DOXYGEN),../..,https://api.libreoffice.org)|g' \
+ -e 's|%JAVADOC_PREFIX0%|$(if $(ENABLE_JAVA),.,https://api.libreoffice.org)|g' \
+ -e 's|%JAVADOC_PREFIX1%|$(if $(ENABLE_JAVA),..,https://api.libreoffice.org)|g' \
+ < $< > $@
+ $(call gb_Trace_EndRange,$*.html,SED)
+
+# vim: set noet sw=4 ts=4: