summaryrefslogtreecommitdiffstats
path: root/odk/examples/java/ConverterServlet
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /odk/examples/java/ConverterServlet
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'odk/examples/java/ConverterServlet')
-rw-r--r--odk/examples/java/ConverterServlet/ConverterServlet.html64
-rw-r--r--odk/examples/java/ConverterServlet/ConverterServlet.java325
-rw-r--r--odk/examples/java/ConverterServlet/Makefile93
-rw-r--r--odk/examples/java/ConverterServlet/README38
-rw-r--r--odk/examples/java/ConverterServlet/web.xml76
5 files changed, 596 insertions, 0 deletions
diff --git a/odk/examples/java/ConverterServlet/ConverterServlet.html b/odk/examples/java/ConverterServlet/ConverterServlet.html
new file mode 100644
index 000000000..7ef0a0db3
--- /dev/null
+++ b/odk/examples/java/ConverterServlet/ConverterServlet.html
@@ -0,0 +1,64 @@
+<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">
+<!--
+ * This file is part of the LibreOffice project.
+ *
+ * This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * This file incorporates work covered by the following license notice:
+ *
+ * Licensed to the Apache Software Foundation (ASF) under one or more
+ * contributor license agreements. See the NOTICE file distributed
+ * with this work for additional information regarding copyright
+ * ownership. The ASF licenses this file to you under the Apache
+ * License, Version 2.0 (the "License"); you may not use this file
+ * except in compliance with the License. You may obtain a copy of
+ * the License at http://www.apache.org/licenses/LICENSE-2.0 .
+-->
+<html><head><title>Document Converter
+</title></head><body>
+<h1>Document Converter</h1>
+<p>Converting documents with a remote running OpenOffice.org.</p>
+<form action="http://localhost:8080/conversion/servlet/ConverterServlet" method=post enctype="multipart/form-data">
+ <table width="510" border="0">
+ <tr>
+ <td>Local document</td>
+ <td>
+ <input type=file size=50 maxlength=100000 name="DocumentToBeConverted">
+ </td>
+ </tr>
+ <tr>
+ <td>Target document type</td>
+ <td>
+ <select name="converttype">
+ <option selected>swriter: StarOffice XML (Writer)</option>
+ <option>swriter: HTML (StarWriter)</option>
+ <option>swriter: MS Word 97</option>
+ <option>swriter: Text</option>
+ <option>scalc: StarOffice XML (Calc)</option>
+ <option>scalc: HTML (StarCalc)</option>
+ <option>scalc: MS Excel 97</option>
+ <option>sdraw: StarOffice XML (Draw)</option>
+ <option>simpress: StarOffice XML (Impress)</option>
+ <option>simpress: MS PowerPoint 97</option>
+ </select>
+ </td>
+ </tr>
+ <tr>
+ <td>Extension</td>
+ <td>
+ <input type=text name="extension">
+ </td>
+ </tr>
+ </table>
+ <p>The converted document will be returned by the server. If you selected the
+ target document type &quot;swriter: HTML (StarWriter)&quot; or &quot;scalc:
+ HTML (StarCalc)&quot;, the document will be shown in the browser. If have an application
+ registered in your browser for the selected document type (mime type) the application will be started.
+ Otherwise, a dialog will be opened, which allows you to open or save the converted document.</p>
+ <p>
+ <input type=submit value="Convert">
+ </p>
+</form>
+</body></html>
diff --git a/odk/examples/java/ConverterServlet/ConverterServlet.java b/odk/examples/java/ConverterServlet/ConverterServlet.java
new file mode 100644
index 000000000..91380ab86
--- /dev/null
+++ b/odk/examples/java/ConverterServlet/ConverterServlet.java
@@ -0,0 +1,325 @@
+/* -*- Mode: Java; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
+/*
+ *
+ * The Contents of this file are made available subject to the terms of
+ * the BSD license.
+ *
+ * Copyright 2000, 2010 Oracle and/or its affiliates.
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ * 3. Neither the name of Sun Microsystems, Inc. nor the names of its
+ * contributors may be used to endorse or promote products derived
+ * from this software without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+ * "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+ * LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
+ * FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
+ * COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+ * INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
+ * BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
+ * OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+ * ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR
+ * TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE
+ * USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ *
+ */
+
+// JDK API
+import java.io.IOException;
+import java.io.PrintWriter;
+import java.io.File;
+import java.util.Enumeration;
+
+// Servlet API
+import javax.servlet.ServletException;
+import javax.servlet.http.HttpServlet;
+import javax.servlet.http.HttpServletRequest;
+import javax.servlet.http.HttpServletResponse;
+// Helper API
+import com.oreilly.servlet.MultipartRequest;
+import com.oreilly.servlet.MultipartResponse;
+import com.oreilly.servlet.ServletUtils;
+
+// UNO API
+import com.sun.star.bridge.XUnoUrlResolver;
+import com.sun.star.uno.XComponentContext;
+import com.sun.star.uno.UnoRuntime;
+import com.sun.star.frame.XComponentLoader;
+import com.sun.star.frame.XStorable;
+import com.sun.star.util.XCloseable;
+import com.sun.star.beans.PropertyValue;
+import com.sun.star.beans.XPropertySet;
+import com.sun.star.lang.XComponent;
+import com.sun.star.lang.XMultiComponentFactory;
+
+
+/** This class implements a http servlet in order to convert an incoming document
+ * with help of a running OpenOffice.org and to push the converted file back
+ * to the client.
+ */
+public class ConverterServlet extends HttpServlet {
+ /** Specifies the temporary directory on the web server.
+ */
+ private String stringWorkingDirectory = System.getProperty( "java.io.tmpdir" ).replace( '\\', '/' );
+
+ /** Specifies the host for the office server.
+ */
+ private static final String stringHost = "localhost";
+
+ /** Specifies the port for the office server.
+ */
+ private static final String stringPort = "2083";
+
+ /** Called by the server (via the service method) to allow a servlet to handle
+ * a POST request. The file from the client will be uploaded to the web server
+ * and converted on the web server and after all pushed to the client.
+ * @param request Object that contains the request the client has made of the servlet.
+ * @param response Object that contains the response the servlet sends to the client.
+ * @throws ServletException If the request for the POST could not be handled.
+ * @throws IOException If an input or output error is detected when the servlet handles the request.
+ */
+ @Override
+ protected void doPost( HttpServletRequest request,
+ HttpServletResponse response) throws ServletException, java.io.IOException {
+ try {
+ // If necessary, add a slash to the end of the string.
+ if ( !stringWorkingDirectory.endsWith( "/" ) ) {
+ stringWorkingDirectory += "/";
+ }
+
+ // Construct a MultipartRequest to help read the information.
+ // Pass in the request, a directory to save files to, and the
+ // maximum POST size we should attempt to handle.
+ MultipartRequest multipartrequest =
+ new MultipartRequest( request, stringWorkingDirectory, 5 * 1024 * 1024 );
+
+ // Getting all file names from the request
+ Enumeration files = multipartrequest.getFileNames();
+
+ // Every received file will be converted to the specified type
+ while (files.hasMoreElements()) {
+ // Getting the name from the element
+ String stringName = (String)files.nextElement();
+
+ // Getting the filename from the request
+ String stringFilename =
+ multipartrequest.getFilesystemName( stringName );
+
+ // Converting the given file on the server to the specified type and
+ // append a special extension
+ File cleanupFile = null;
+ String stringSourceFile = stringWorkingDirectory + stringFilename;
+
+ try {
+ String stringConvertedFile = convertDocument(stringSourceFile,
+ multipartrequest.getParameter( "converttype" ),
+ multipartrequest.getParameter( "extension" ));
+
+ String shortFileName = stringConvertedFile.substring(
+ stringConvertedFile.lastIndexOf('/') + 1);
+
+ // Set the response header
+ // Set the filename, is used when the file will be saved (problem with mozilla)
+ response.addHeader( "Content-Disposition",
+ "attachment; filename=" + shortFileName);
+
+ // Constructing the multi part response to the client
+ MultipartResponse multipartresponse = new MultipartResponse(response);
+
+ // Is the convert type HTML?
+ if ( ( multipartrequest.getParameter( "converttype" ).equals(
+ "swriter: HTML (StarWriter)" ) )
+ || ( multipartrequest.getParameter( "converttype" ).equals(
+ "scalc: HTML (StarCalc)" ) ) ) {
+ // Setting the content type of the response being sent to the client
+ // to text
+ multipartresponse.startResponse( "text/html" );
+ } else {
+ // Setting the content type of the response being sent to the client
+ // to application/octet-stream so that file will open a dialog box
+ // at the client in order to save the converted file
+ multipartresponse.startResponse( "application/octet-stream" );
+ }
+
+ // Pushing the converted file to the client
+ ServletUtils.returnFile( stringConvertedFile,
+ response.getOutputStream() );
+
+ // Finishing the multi part response
+ multipartresponse.finish();
+
+ // clean up the working directory
+ cleanupFile = new File(stringConvertedFile);
+ if ( cleanupFile.exists() )
+ cleanupFile.delete();
+
+ } catch (Exception exc) {
+ response.setContentType( "text/html;charset=8859-1" );
+ PrintWriter out = response.getWriter();
+
+ exc.printStackTrace();
+
+ out.println( "<html><head>" );
+ out.println( " <title>" + "SDK Converter Servlet" + "</title>" );
+ out.println( "</head>" );
+ out.println( "<body><br><p>");
+ out.println( "<b>Sorry, the conversion failed!</b></p>");
+ out.println( "<p><b>Error Message:</b><br>" + exc.getMessage() + "<br>");
+ exc.printStackTrace(out);
+ out.println( "</p></body><html>");
+ }
+
+ // clean up the working directory
+ cleanupFile = new File(stringSourceFile);
+ if ( cleanupFile.exists() )
+ cleanupFile.delete();
+ }
+ }
+ catch (Exception exception) {
+ System.err.println( exception.toString() );
+ }
+ }
+
+ /** This method converts a document to a given type by using a running
+ * OpenOffice.org and saves the converted document to the specified
+ * working directory.
+ * @param stringDocumentName The full path name of the file on the server to be converted.
+ * @param stringConvertType Type to convert to.
+ * @param stringExtension This string will be appended to the file name of the converted file.
+ * @return The full path name of the converted file will be returned.
+ * @see stringWorkingDirectory
+ */
+ private String convertDocument( String stringDocumentName,
+ String stringConvertType,
+ String stringExtension)
+ throws Exception
+ {
+ String stringConvertedFile = "";
+
+ // Converting the document to the favoured type
+// try {
+ // Composing the URL
+ String stringUrl = "file:///" + stringDocumentName;
+
+ /* Bootstraps a component context with the jurt base components
+ registered. Component context to be granted to a component for running.
+ Arbitrary values can be retrieved from the context. */
+ XComponentContext xcomponentcontext =
+ com.sun.star.comp.helper.Bootstrap.createInitialComponentContext( null );
+
+ /* Gets the service manager instance to be used (or null). This method has
+ been added for convenience, because the service manager is an often used
+ object. */
+ XMultiComponentFactory xmulticomponentfactory =
+ xcomponentcontext.getServiceManager();
+
+ /* Creates an instance of the component UnoUrlResolver which
+ supports the services specified by the factory. */
+ Object objectUrlResolver =
+ xmulticomponentfactory.createInstanceWithContext(
+ "com.sun.star.bridge.UnoUrlResolver", xcomponentcontext );
+
+ // Create a new url resolver
+ XUnoUrlResolver xurlresolver = UnoRuntime.queryInterface( XUnoUrlResolver.class,
+ objectUrlResolver );
+
+ // Resolves an object that is specified as follow:
+ // uno:<connection description>;<protocol description>;<initial object name>
+ Object objectInitial = xurlresolver.resolve(
+ "uno:socket,host=" + stringHost + ",port=" + stringPort +
+ ";urp;StarOffice.ServiceManager" );
+
+ // Create a service manager from the initial object
+ xmulticomponentfactory = UnoRuntime.queryInterface( XMultiComponentFactory.class, objectInitial );
+
+ // Query for the XPropertySet interface.
+ XPropertySet xpropertysetMultiComponentFactory = UnoRuntime.queryInterface( XPropertySet.class, xmulticomponentfactory );
+
+ // Get the default context from the office server.
+ Object objectDefaultContext =
+ xpropertysetMultiComponentFactory.getPropertyValue( "DefaultContext" );
+
+ // Query for the interface XComponentContext.
+ xcomponentcontext = UnoRuntime.queryInterface(
+ XComponentContext.class, objectDefaultContext );
+
+ /* A desktop environment contains tasks with one or more
+ frames in which components can be loaded. Desktop is the
+ environment for components which can instantiate within
+ frames. */
+ XComponentLoader xcomponentloader = UnoRuntime.queryInterface( XComponentLoader.class,
+ xmulticomponentfactory.createInstanceWithContext(
+ "com.sun.star.frame.Desktop", xcomponentcontext ) );
+
+ // Preparing properties for loading the document
+ PropertyValue propertyvalue[] = new PropertyValue[ 1 ];
+ // Setting the flag to hide the open document
+ propertyvalue[ 0 ] = new PropertyValue();
+ propertyvalue[ 0 ].Name = "Hidden";
+ propertyvalue[ 0 ].Value = Boolean.TRUE;
+
+ // Loading the wanted document
+ Object objectDocumentToStore =
+ xcomponentloader.loadComponentFromURL(
+ stringUrl, "_blank", 0, propertyvalue );
+
+ // Getting an object that will offer a simple way to store a document to a URL.
+ XStorable xstorable =
+ UnoRuntime.queryInterface( XStorable.class,
+ objectDocumentToStore );
+
+ // Preparing properties for converting the document
+ propertyvalue = new PropertyValue[ 2 ];
+ // Setting the flag for overwriting
+ propertyvalue[ 0 ] = new PropertyValue();
+ propertyvalue[ 0 ].Name = "Overwrite";
+ propertyvalue[ 0 ].Value = Boolean.TRUE;
+ // Setting the filter name
+ propertyvalue[ 1 ] = new PropertyValue();
+ propertyvalue[ 1 ].Name = "FilterName";
+ propertyvalue[ 1 ].Value = stringConvertType;
+
+ // Appending the favoured extension to the origin document name
+ int index = stringUrl.lastIndexOf('.');
+ if ( index >= 0 ) {
+ stringConvertedFile = stringUrl.substring(0, index) + "." + stringExtension;
+ } else {
+ stringConvertedFile = stringUrl + "." + stringExtension;
+ }
+
+ // Storing and converting the document
+ xstorable.storeAsURL( stringConvertedFile, propertyvalue );
+
+ XCloseable xcloseable = UnoRuntime.queryInterface( XCloseable.class,xstorable );
+
+ // Closing the converted document
+ if ( xcloseable != null )
+ xcloseable.close(false);
+ else {
+ // If Xcloseable is not supported (older versions,
+ // use dispose() for closing the document
+ XComponent xComponent = UnoRuntime.queryInterface(
+ XComponent.class, xstorable );
+ xComponent.dispose();
+ }
+
+ if ( stringConvertedFile.startsWith( "file:///" ) ) {
+ // Truncating the beginning of the file name
+ stringConvertedFile = stringConvertedFile.substring( 8 );
+ }
+
+ // Returning the name of the converted file
+ return stringConvertedFile;
+ }
+}
+
+/* vim:set shiftwidth=4 softtabstop=4 expandtab: */
diff --git a/odk/examples/java/ConverterServlet/Makefile b/odk/examples/java/ConverterServlet/Makefile
new file mode 100644
index 000000000..2dff683c3
--- /dev/null
+++ b/odk/examples/java/ConverterServlet/Makefile
@@ -0,0 +1,93 @@
+#*************************************************************************
+#
+# The Contents of this file are made available subject to the terms of
+# the BSD license.
+#
+# Copyright 2000, 2010 Oracle and/or its affiliates.
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+# 1. Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# 2. Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in the
+# documentation and/or other materials provided with the distribution.
+# 3. Neither the name of Sun Microsystems, Inc. nor the names of its
+# contributors may be used to endorse or promote products derived
+# from this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
+# FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
+# COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+# INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
+# BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
+# OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR
+# TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE
+# USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+#**************************************************************************
+
+# Builds the Java ConverterServlet example of the SDK.
+
+PRJ=../../..
+SETTINGS=$(PRJ)/settings
+
+include $(SETTINGS)/settings.mk
+include $(SETTINGS)/std.mk
+
+# Define non-platform/compiler specific settings
+COMPONENT_NAME=ConverterServletExample
+OUT_COMP_CLASS=$(OUT_CLASS)/$(COMPONENT_NAME)
+
+JAVAFILES = \
+ ConverterServlet.java
+
+CLASSFILES = $(patsubst %.java,$(OUT_COMP_CLASS)/%.class,$(JAVAFILES))
+
+SDK_CLASSPATH = $(subst $(EMPTYSTRING) $(PATH_SEPARATOR),$(PATH_SEPARATOR),$(CLASSPATH)\
+ $(PATH_SEPARATOR)$(OFFICE_CLASSES_DIR)/cos.jar\
+ $(PATH_SEPARATOR)$(OFFICE_CLASSES_DIR)/servlet.jar\
+ $(PATH_SEPARATOR)$(OUT_COMP_CLASS))
+
+# Targets
+.PHONY: ALL
+ALL : \
+ ConverterServletExample
+
+include $(SETTINGS)/stdtarget.mk
+
+$(OFFICE_CLASSES_DIR)/cos.jar :
+ @echo --------------------------------------------------------------------------------
+ @echo You need the servlet support Java archive "$(QM)cos.jar$(QM)" for this example.
+ @echo You can download it from "$(QM)http://www.servlets.com/cos/index.html$(QM)"
+ @echo and then please copy it into your "$(QM)$(OFFICE_CLASSES_DIR)$(QM)" directory.
+ @echo --------------------------------------------------------------------------------
+
+$(OFFICE_CLASSES_DIR)/servlet.jar :
+ @echo --------------------------------------------------------------------------------
+ @echo You need the servlet API "$(QM)servlet.jar$(QM)" for this example.
+ @echo You can download it from "$(QM)http://java.sun.com/products/servlet/index.html$(QM)"
+ @echo and then please copy it into your "$(QM)$(OFFICE_CLASSES_DIR)$(QM)" directory.
+ @echo --------------------------------------------------------------------------------
+
+$(CLASSFILES) : $(JAVAFILES) $(OFFICE_CLASSES_DIR)/cos.jar $(OFFICE_CLASSES_DIR)/servlet.jar
+ -$(MKDIR) $(subst /,$(PS),$(@D))
+ $(SDK_JAVAC) $(JAVAC_FLAGS) -classpath "$(SDK_CLASSPATH)" -d $(OUT_COMP_CLASS) $(JAVAFILES)
+
+ConverterServletExample : $(CLASSFILES)
+ @echo --------------------------------------------------------------------------------
+ @echo Please see the README file for more information how to use the converter
+ @echo servlet.
+ @echo --------------------------------------------------------------------------------
+
+%.run: $(OUT_COMP_CLASS)/%.class
+ $(JAVA) -classpath "$(SDK_CLASSPATH)" $(basename $@)
+
+.PHONY: clean
+clean :
+ -$(DELRECURSIVE) $(subst /,$(PS),$(OUT_COMP_CLASS))
diff --git a/odk/examples/java/ConverterServlet/README b/odk/examples/java/ConverterServlet/README
new file mode 100644
index 000000000..ea59b80b4
--- /dev/null
+++ b/odk/examples/java/ConverterServlet/README
@@ -0,0 +1,38 @@
+Servlet for converting documents
+================================
+
+Build preparation:
+==================
+In the file "ConverterServlet.html", search for the following line:
+<form action="http://localhost:8080/conversion/servlet/ConverterServlet" method=post enctype="multipart/form-data">
+Replace the existing IP address (localhost) with your intended IP address.
+
+Installation instructions:
+==========================
+1. If no web server is available you should install your favourite web server.
+ The example was tested with a Tomcat 4.1 server (http://jakarta.apache.org/tomcat/)
+2. Download the servlet support Java archive (cos.jar) from
+ http://www.servlets.com/cos/index.html and copy the file to the directory
+ <OFFICE_HOME>/program/classes. If you don't use the created WAR (WAR = simple web archive file, it
+ is similar to a normal Jar file) file, please make these classes also known to your web server.
+3. You need also the Servlet API (servlet.jar). The Tomcat server comes with this Servlet API. Please
+ copy the file "servlet.jar" to the directory <OFFICE_HOME>/program/classes.
+ If you don't use the Tomcat server, make sure that the Servlet API is in the classpath of your web
+ server. You can download the Servlet API from http://java.sun.com/products/servlet/index.html .
+4. Use your GNU make (http://www.gnu.org) to build the servlet class.
+5. Make the servlet class known to your web server.
+ The example creates also a WAR file which can be easy deployed in a Tomcat server.
+ 5.1 Browse the 'Tomcat Web Application Manager'
+ 5.2 Navigate into the section 'Upload a WAR file to install'
+ 5.3 Browse to your generated WAR file and select it
+ 5.4 install it
+
+
+Converting documents with the servlet:
+======================================
+1. Browse your web server "http://<your_ip>/conversion/ConverterServlet.html" or
+ open the file "ConverterServlet.html" in your web browser and select a file.
+2. Select a type to convert the file to, and the extension for the converted file.
+3. Press the button. The document will be uploaded to the server, converted and
+ pushed back to the client. Your browser will open a dialog for saving the
+ converted document.
diff --git a/odk/examples/java/ConverterServlet/web.xml b/odk/examples/java/ConverterServlet/web.xml
new file mode 100644
index 000000000..10dfde5ec
--- /dev/null
+++ b/odk/examples/java/ConverterServlet/web.xml
@@ -0,0 +1,76 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!--
+ * This file is part of the LibreOffice project.
+ *
+ * This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * This file incorporates work covered by the following license notice:
+ *
+ * Licensed to the Apache Software Foundation (ASF) under one or more
+ * contributor license agreements. See the NOTICE file distributed
+ * with this work for additional information regarding copyright
+ * ownership. The ASF licenses this file to you under the Apache
+ * License, Version 2.0 (the "License"); you may not use this file
+ * except in compliance with the License. You may obtain a copy of
+ * the License at http://www.apache.org/licenses/LICENSE-2.0 .
+-->
+<project name="MinimalComponent" basedir="." default="all">
+
+ <target name="init">
+ <!--
+ In this target you have to change all parts, so that the properties
+ fit to your odk installation and to your service
+ -->
+ <property name="ODKPATH" value="D:/cvs/api/odk"/>
+ <property name="OUTPUTPATH" value="D:/cvs/api/odk/WINexample.out"/>
+ <property name="PACKAGE_NAME" value="org.OpenOffice."/>
+ <property name="JAR_FILE_NAME" value="MinimalComponent"/>
+ <property name="INTERFACE_NAME" value="MinimalComponent"/>
+ <property name="RDB_NAME" value="MinimalComponent.rdb"/>
+ </target>
+ <target depends="init" name="unoidl">
+
+ <exec dir="${ODKPATH}/WINexample.out/misc/" executable="${ODKPATH}/windows/bin/idlc.exe" timeout="600">
+ <arg line="-I. -I${ODKPATH}/idl ${ODKPATH}/examples/java/MinimalComponent/${INTERFACE_NAME}.idl"/>
+ </exec>
+
+ <exec dir="." executable="${ODKPATH}/windows/bin/regmerge.exe" timeout="600">
+ <arg line="./${RDB_NAME} /UCR ./${INTERFACE_NAME}.urd"/>
+ </exec>
+
+ <exec dir="." executable="${ODKPATH}/windows/bin/regmerge.exe" timeout="600">
+ <arg line="./${RDB_NAME} / ${ODKPATH}/windows/bin/applicat.rdb"/>
+ </exec>
+
+ <exec dir="." executable="${ODKPATH}/windows/bin/javamaker.exe" timeout="600">
+ <arg line="-O${OUTPUTPATH}/class/${INTERFACE_NAME} -nD ./${RDB_NAME}"/>
+<!--
+ <arg line="-T${PACKAGE_NAME}${INTERFACE_NAME} -O${OUTPUTPATH}/class/${INTERFACE_NAME} -nD ./${INTERFACE_NAME}.urd"/>
+ -->
+ </exec>
+
+ </target>
+
+ <target depends="init,unoidl" name="compile">
+ <mkdir dir="classes"/>
+ <javac debug="on" destdir="./classes" srcdir="." >
+ <classpath>
+ <fileset dir="${ODKPATH}/classes/">
+ <include name="**/*.jar"/>
+ </fileset>
+ <pathelement location="./classes"/>
+ </classpath>
+ </javac>
+ </target>
+
+ <target depends="compile,init" name="jar">
+ <jar basedir="./classes" compress="true" jarfile="${JAR_FILE_NAME}.jar" manifest="Manifest">
+ </jar>
+ </target>
+
+ <target depends="compile,init,jar" name="all">
+ <!-- WRITEME -->
+ </target>
+</project>