summaryrefslogtreecommitdiffstats
path: root/onlineupdate/StaticLibrary_updatehelper.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /onlineupdate/StaticLibrary_updatehelper.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--onlineupdate/StaticLibrary_updatehelper.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/onlineupdate/StaticLibrary_updatehelper.mk b/onlineupdate/StaticLibrary_updatehelper.mk
new file mode 100644
index 000000000..1c3654cbc
--- /dev/null
+++ b/onlineupdate/StaticLibrary_updatehelper.mk
@@ -0,0 +1,31 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_StaticLibrary_StaticLibrary,updatehelper))
+
+$(eval $(call gb_StaticLibrary_set_include,updatehelper,\
+ -I$(SRCDIR)/onlineupdate/inc/ \
+ -I$(SRCDIR)/onlineupdate/source/update/common \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_StaticLibrary_add_defs,updatehelper,\
+ -DNSS3 \
+ -DVERIFY_MAR_SIGNATURE \
+))
+
+$(eval $(call gb_StaticLibrary_add_exception_objects,updatehelper,\
+ onlineupdate/source/update/common/pathhash \
+ onlineupdate/source/update/common/readstrings \
+ onlineupdate/source/update/common/uachelper \
+ onlineupdate/source/update/common/updatehelper \
+ onlineupdate/source/update/common/updatelogging \
+))
+
+# vim:set shiftwidth=4 tabstop=4 noexpandtab: */