summaryrefslogtreecommitdiffstats
path: root/pch/inc/clangfix.hxx
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /pch/inc/clangfix.hxx
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'pch/inc/clangfix.hxx')
-rw-r--r--pch/inc/clangfix.hxx31
1 files changed, 31 insertions, 0 deletions
diff --git a/pch/inc/clangfix.hxx b/pch/inc/clangfix.hxx
new file mode 100644
index 000000000..7280032ba
--- /dev/null
+++ b/pch/inc/clangfix.hxx
@@ -0,0 +1,31 @@
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
+/*
+ * This file is part of the LibreOffice project.
+ *
+ * This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ */
+
+#ifdef __clang__
+// This is a bit lame, but when using -DMACRO that wasn't present when the PCH was built,
+// Clang suddenly subjects it to the -Wunused-macros check, which isn't the case otherwise.
+// And many of these macros are not actually used. So use them here to silence the warnings.
+// See gb_PrecompiledHeader_ignore_flags_system in solenv/gbuild/PrecompiledHeaders.mk .
+
+#ifdef FASTSAX_DLLIMPLEMENTATION
+#endif
+#ifdef SAX_DLLIMPLEMENTATION
+#endif
+#ifdef SCQAHELPER_DLLIMPLEMENTATION
+#endif
+#ifdef SYSTEM_EXPAT
+#endif
+#ifdef SYSTEM_LIBXML
+#endif
+#ifdef SYSTEM_ZLIB
+#endif
+
+#endif // __clang__
+
+/* vim:set shiftwidth=4 softtabstop=4 expandtab: */