summaryrefslogtreecommitdiffstats
path: root/registry/CustomTarget_regcompare_test.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /registry/CustomTarget_regcompare_test.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'registry/CustomTarget_regcompare_test.mk')
-rw-r--r--registry/CustomTarget_regcompare_test.mk213
1 files changed, 213 insertions, 0 deletions
diff --git a/registry/CustomTarget_regcompare_test.mk b/registry/CustomTarget_regcompare_test.mk
new file mode 100644
index 000000000..e7816301f
--- /dev/null
+++ b/registry/CustomTarget_regcompare_test.mk
@@ -0,0 +1,213 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,registry/regcompare_test))
+
+.PHONY: $(call gb_CustomTarget_get_target,registry/regcompare_test)
+
+$(call gb_CustomTarget_get_target,registry/regcompare_test): \
+ $(call gb_Executable_get_runtime_dependencies,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/other1.rdb \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/other2.rdb \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/pe.rdb \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/psa.rdb \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/psb.rdb \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/ue.rdb \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/usa.rdb \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/usb.rdb
+ifneq ($(gb_SUPPRESS_TESTS),)
+ @true
+else
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/psa.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/psb.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/usa.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/usb.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/pe.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/ue.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/other1.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/other2.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/psa.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/psb.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/usa.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/usb.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/pe.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/ue.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/other1.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/other2.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/psa.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/psb.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/usa.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/usb.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/pe.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/ue.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/other1.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/other2.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/psa.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/psb.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/usa.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/usb.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/pe.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/ue.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/other1.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/other2.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+endif
+
+$(call gb_CustomTarget_get_workdir,registry/regcompare_test)/%.rdb: \
+ $(call gb_CustomTarget_get_workdir,registry/regcompare_test)/%.urd \
+ $(call gb_Executable_get_runtime_dependencies,regmerge)
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(call gb_Executable_get_command,regmerge) $@ /UCR $<))
+
+$(call gb_CustomTarget_get_workdir,registry/regcompare_test)/%.urd: \
+ $(SRCDIR)/registry/test/regcompare/%.idl \
+ $(call gb_Executable_get_runtime_dependencies,idlc)
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(call gb_Executable_get_command,idlc) \
+ -O$(call gb_CustomTarget_get_workdir,registry/regcompare_test) \
+ -cid -we $<))
+
+# vim: set noet sw=4 ts=4: