summaryrefslogtreecommitdiffstats
path: root/sdext/Executable_pdf2xml.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /sdext/Executable_pdf2xml.mk
parentInitial commit. (diff)
downloadlibreoffice-1ad18e38974bb28c3d98d0be8f7d8c18fc56de29.tar.xz
libreoffice-1ad18e38974bb28c3d98d0be8f7d8c18fc56de29.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'sdext/Executable_pdf2xml.mk')
-rw-r--r--sdext/Executable_pdf2xml.mk43
1 files changed, 43 insertions, 0 deletions
diff --git a/sdext/Executable_pdf2xml.mk b/sdext/Executable_pdf2xml.mk
new file mode 100644
index 000000000..b2439164a
--- /dev/null
+++ b/sdext/Executable_pdf2xml.mk
@@ -0,0 +1,43 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,pdf2xml))
+
+$(eval $(call gb_Executable_use_sdk_api,pdf2xml))
+
+$(eval $(call gb_Executable_use_externals,pdf2xml,\
+ boost_headers \
+ cppunit \
+ zlib \
+))
+
+$(eval $(call gb_Executable_set_include,pdf2xml,\
+ -I$(SRCDIR)/sdext/source/pdfimport/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_Executable_use_libraries,pdf2xml,\
+ basegfx \
+ vcl \
+ comphelper \
+ cppu \
+ unotest \
+ cppuhelper \
+ sal \
+ tl \
+ xo \
+))
+
+$(eval $(call gb_Executable_use_library_objects,pdf2xml,pdfimport))
+
+$(eval $(call gb_Executable_add_exception_objects,pdf2xml,\
+ sdext/source/pdfimport/test/pdf2xml \
+))
+
+# vim:set noet sw=4 ts=4: