summaryrefslogtreecommitdiffstats
path: root/sdext/Module_sdext.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /sdext/Module_sdext.mk
parentInitial commit. (diff)
downloadlibreoffice-1ad18e38974bb28c3d98d0be8f7d8c18fc56de29.tar.xz
libreoffice-1ad18e38974bb28c3d98d0be8f7d8c18fc56de29.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'sdext/Module_sdext.mk')
-rw-r--r--sdext/Module_sdext.mk40
1 files changed, 40 insertions, 0 deletions
diff --git a/sdext/Module_sdext.mk b/sdext/Module_sdext.mk
new file mode 100644
index 000000000..fd1d191b4
--- /dev/null
+++ b/sdext/Module_sdext.mk
@@ -0,0 +1,40 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,sdext))
+
+$(eval $(call gb_Module_add_targets,sdext,\
+ Library_PresenterScreen \
+))
+
+$(eval $(call gb_Module_add_targets,sdext,\
+ Library_PresentationMinimizer \
+))
+
+ifeq ($(ENABLE_PDFIMPORT),TRUE)
+$(eval $(call gb_Module_add_targets,sdext,\
+ CustomTarget_pdfimport \
+ Library_pdfimport \
+))
+
+ifeq ($(ENABLE_POPPLER),TRUE)
+$(eval $(call gb_Module_add_targets,sdext,\
+ Executable_xpdfimport \
+ Package_pdfimport_xpdfimport \
+))
+endif
+
+$(eval $(call gb_Module_add_check_targets,sdext,\
+ CppunitTest_sdext_pdfimport \
+ Executable_pdf2xml \
+ Executable_pdfunzip \
+))
+endif
+
+# vim:set noet sw=4 ts=4: