summaryrefslogtreecommitdiffstats
path: root/setup_native/StaticLibrary_seterror.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /setup_native/StaticLibrary_seterror.mk
parentInitial commit. (diff)
downloadlibreoffice-upstream.tar.xz
libreoffice-upstream.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--setup_native/StaticLibrary_seterror.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/setup_native/StaticLibrary_seterror.mk b/setup_native/StaticLibrary_seterror.mk
new file mode 100644
index 000000000..922976904
--- /dev/null
+++ b/setup_native/StaticLibrary_seterror.mk
@@ -0,0 +1,24 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_StaticLibrary_StaticLibrary,seterror))
+
+$(eval $(call gb_StaticLibrary_add_defs,seterror,\
+ -U_DLL \
+))
+
+$(eval $(call gb_StaticLibrary_add_cxxflags,seterror,\
+ $(if $(MSVC_USE_DEBUG_RUNTIME),/MTd,/MT) \
+))
+
+$(eval $(call gb_StaticLibrary_add_exception_objects,seterror,\
+ setup_native/source/win32/customactions/tools/seterror \
+))
+
+# vim: set noet sw=4 ts=4: