summaryrefslogtreecommitdiffstats
path: root/shell/CustomTarget_shlxthdl_res.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /shell/CustomTarget_shlxthdl_res.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'shell/CustomTarget_shlxthdl_res.mk')
-rw-r--r--shell/CustomTarget_shlxthdl_res.mk42
1 files changed, 42 insertions, 0 deletions
diff --git a/shell/CustomTarget_shlxthdl_res.mk b/shell/CustomTarget_shlxthdl_res.mk
new file mode 100644
index 000000000..2780958cf
--- /dev/null
+++ b/shell/CustomTarget_shlxthdl_res.mk
@@ -0,0 +1,42 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,shell/source/win32/shlxthandler/res))
+
+$(eval $(call gb_CustomTarget_register_targets,shell/source/win32/shlxthandler/res,\
+ shlxthdl.ulf \
+ shlxthdl_impl.rc \
+))
+
+$(call gb_CustomTarget_get_workdir,shell/source/win32/shlxthandler/res)/shlxthdl_impl.rc : \
+ $(call gb_CustomTarget_get_workdir,shell/source/win32/shlxthandler/res)/shlxthdl.ulf \
+ $(SRCDIR)/shell/source/win32/shlxthandler/res/rcfooter.txt \
+ $(SRCDIR)/shell/source/win32/shlxthandler/res/rcheader.txt \
+ $(SRCDIR)/shell/source/win32/shlxthandler/res/rctmpl.txt \
+ $(call gb_Executable_get_runtime_dependencies,lngconvex)
+ $(call gb_Output_announce,$(subst $(WORKDIR)/,,$@),$(true),LCX,1)
+ $(call gb_Trace_StartRange,$(subst $(WORKDIR)/,,$@),LCX)
+ $(call gb_Helper_abbreviate_dirs,\
+ cd $(SRCDIR)/shell/source/win32/shlxthandler/res && \
+ BRAND_BASE_DIR=$(call gb_Helper_make_url,$(INSTROOT)) \
+ $(call gb_Executable_get_command,lngconvex) \
+ -ulf $< \
+ -rc $@ \
+ -rct rctmpl.txt \
+ -rch rcheader.txt \
+ -rcf rcfooter.txt)
+ $(call gb_Trace_EndRange,$(subst $(WORKDIR)/,,$@),LCX)
+
+$(eval $(call gb_CustomTarget_ulfex_rule,\
+ $(call gb_CustomTarget_get_workdir,shell/source/win32/shlxthandler/res)/shlxthdl.ulf,\
+ $(SRCDIR)/shell/source/win32/shlxthandler/res/shlxthdl.ulf,\
+ $(foreach lang,$(gb_TRANS_LANGS),\
+ $(gb_POLOCATION)/$(lang)/shell/source/win32/shlxthandler/res.po)))
+
+# vim: set shiftwidth=4 tabstop=4 noexpandtab: