summaryrefslogtreecommitdiffstats
path: root/shell/CustomTarget_x64.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /shell/CustomTarget_x64.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'shell/CustomTarget_x64.mk')
-rw-r--r--shell/CustomTarget_x64.mk69
1 files changed, 69 insertions, 0 deletions
diff --git a/shell/CustomTarget_x64.mk b/shell/CustomTarget_x64.mk
new file mode 100644
index 000000000..79dcde80d
--- /dev/null
+++ b/shell/CustomTarget_x64.mk
@@ -0,0 +1,69 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,shell/source))
+
+SHELL_SHLXTHANDLER_COMMON_FILES := \
+ win32/ooofilereader/autostyletag \
+ win32/ooofilereader/basereader \
+ win32/ooofilereader/contentreader \
+ win32/ooofilereader/keywordstag \
+ win32/ooofilereader/metainforeader \
+ win32/ooofilereader/simpletag \
+ win32/shlxthandler/ooofilt/stream_helper \
+ win32/shlxthandler/util/fileextensions \
+ win32/shlxthandler/util/iso8601_converter \
+ win32/shlxthandler/util/registry \
+ win32/shlxthandler/util/utilities \
+ win32/zipfile/zipexcptn \
+ win32/zipfile/zipfile
+
+SHELL_SHLXTHDL_FILES := \
+ win32/shlxthandler/classfactory \
+ win32/shlxthandler/columninfo/columninfo \
+ win32/shlxthandler/infotips/infotips \
+ win32/shlxthandler/propsheets/document_statistic \
+ win32/shlxthandler/propsheets/listviewbuilder \
+ win32/shlxthandler/propsheets/propsheets \
+ win32/shlxthandler/shlxthdl \
+ win32/shlxthandler/thumbviewer/thumbviewer
+
+SHELL_OOOFILT_FILES := \
+ win32/shlxthandler/ooofilt/ooofilt \
+ win32/shlxthandler/ooofilt/propspec
+
+SHELL_PROPERTYHDL_FILES := \
+ win32/shlxthandler/prophdl/propertyhdl
+
+SHELL_XMLPARSER_FILES := \
+ all/xml_parser
+
+SHELL_HEADERS := \
+ win32/ooofilereader/autostyletag \
+ win32/ooofilereader/dummytag \
+ win32/ooofilereader/itag \
+ win32/ooofilereader/keywordstag \
+ win32/ooofilereader/simpletag \
+ win32/shlxthandler/classfactory \
+ win32/shlxthandler/ooofilt/ooofilt \
+ win32/shlxthandler/ooofilt/propspec \
+ win32/shlxthandler/propsheets/document_statistic \
+ win32/shlxthandler/propsheets/listviewbuilder \
+ win32/zipfile/zipexcptn
+
+$(call gb_CustomTarget_get_target,shell/source) : \
+ $(foreach source,$(SHELL_SHLXTHANDLER_COMMON_FILES) $(SHELL_SHLXTHDL_FILES) $(SHELL_OOOFILT_FILES) $(SHELL_PROPERTYHDL_FILES) $(SHELL_XMLPARSER_FILES),\
+ $(call gb_CustomTarget_get_workdir,shell/source)/$(source).cxx) \
+ $(foreach header,$(SHELL_HEADERS),\
+ $(call gb_CustomTarget_get_workdir,shell/source)/$(header).hxx)
+
+$(call gb_CustomTarget_get_workdir,shell/source)/% : $(SRCDIR)/shell/source/%
+ mkdir -p $(dir $@) && $(call gb_Deliver_deliver,$<,$@)
+
+# vim: set shiftwidth=4 tabstop=4 noexpandtab: