summaryrefslogtreecommitdiffstats
path: root/shell/Library_smplmail.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /shell/Library_smplmail.mk
parentInitial commit. (diff)
downloadlibreoffice-upstream/1%7.0.4.tar.xz
libreoffice-upstream/1%7.0.4.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'shell/Library_smplmail.mk')
-rw-r--r--shell/Library_smplmail.mk36
1 files changed, 36 insertions, 0 deletions
diff --git a/shell/Library_smplmail.mk b/shell/Library_smplmail.mk
new file mode 100644
index 000000000..fa8c22294
--- /dev/null
+++ b/shell/Library_smplmail.mk
@@ -0,0 +1,36 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,smplmail))
+
+$(eval $(call gb_Library_use_sdk_api,smplmail))
+
+$(eval $(call gb_Library_use_system_win32_libs,smplmail,\
+ advapi32 \
+))
+
+$(eval $(call gb_Library_use_libraries,smplmail,\
+ cppu \
+ cppuhelper \
+ i18nlangtag \
+ sal \
+ tl \
+ utl \
+))
+
+$(eval $(call gb_Library_set_componentfile,smplmail,shell/source/win32/simplemail/smplmail))
+
+$(eval $(call gb_Library_add_exception_objects,smplmail,\
+ shell/source/win32/simplemail/smplmailclient \
+ shell/source/win32/simplemail/smplmailentry \
+ shell/source/win32/simplemail/smplmailmsg \
+ shell/source/win32/simplemail/smplmailsuppl \
+))
+
+# vim: set shiftwidth=4 tabstop=4 noexpandtab: