summaryrefslogtreecommitdiffstats
path: root/shell/Library_syssh.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /shell/Library_syssh.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'shell/Library_syssh.mk')
-rw-r--r--shell/Library_syssh.mk50
1 files changed, 50 insertions, 0 deletions
diff --git a/shell/Library_syssh.mk b/shell/Library_syssh.mk
new file mode 100644
index 000000000..cd64791f1
--- /dev/null
+++ b/shell/Library_syssh.mk
@@ -0,0 +1,50 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,syssh))
+
+$(eval $(call gb_Library_use_sdk_api,syssh))
+
+$(eval $(call gb_Library_use_libraries,syssh,\
+ cppu \
+ cppuhelper \
+ comphelper \
+ sal \
+))
+
+ifeq ($(OS),WNT)
+
+$(eval $(call gb_Library_use_system_win32_libs,syssh,\
+ ole32 \
+ shell32 \
+))
+
+$(eval $(call gb_Library_set_componentfile,syssh,shell/source/win32/syssh))
+
+$(eval $(call gb_Library_add_exception_objects,syssh,\
+ shell/source/win32/SysShExec \
+ shell/source/win32/SysShentry \
+))
+
+else # OS != WNT
+
+$(eval $(call gb_Library_use_static_libraries,syssh,\
+ shell_xmlparser \
+))
+
+$(eval $(call gb_Library_set_componentfile,syssh,shell/source/unix/exec/syssh))
+
+$(eval $(call gb_Library_add_exception_objects,syssh,\
+ shell/source/unix/exec/shellexec \
+ shell/source/unix/exec/shellexecentry \
+))
+
+endif # OS
+
+# vim: set shiftwidth=4 tabstop=4 noexpandtab: