summaryrefslogtreecommitdiffstats
path: root/slideshow/CppunitTest_slideshow.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /slideshow/CppunitTest_slideshow.mk
parentInitial commit. (diff)
downloadlibreoffice-1ad18e38974bb28c3d98d0be8f7d8c18fc56de29.tar.xz
libreoffice-1ad18e38974bb28c3d98d0be8f7d8c18fc56de29.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'slideshow/CppunitTest_slideshow.mk')
-rw-r--r--slideshow/CppunitTest_slideshow.mk47
1 files changed, 47 insertions, 0 deletions
diff --git a/slideshow/CppunitTest_slideshow.mk b/slideshow/CppunitTest_slideshow.mk
new file mode 100644
index 000000000..ae17f66d8
--- /dev/null
+++ b/slideshow/CppunitTest_slideshow.mk
@@ -0,0 +1,47 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,slideshow))
+
+$(eval $(call gb_CppunitTest_set_include,slideshow,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/slideshow/source/inc \
+))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,slideshow))
+
+$(eval $(call gb_CppunitTest_use_library_objects,slideshow,slideshow))
+
+$(eval $(call gb_CppunitTest_use_libraries,slideshow,\
+ $(call gb_Helper_optional,AVMEDIA,avmedia) \
+ basegfx \
+ canvastools \
+ comphelper \
+ cppcanvas \
+ cppu \
+ cppuhelper \
+ sal \
+ salhelper \
+ svl \
+ svt \
+ svx \
+ svxcore \
+ tl \
+ utl \
+ vcl \
+))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,slideshow,\
+ slideshow/test/slidetest \
+ slideshow/test/testshape \
+ slideshow/test/testview \
+ slideshow/test/views \
+))
+
+# vim: set noet sw=4 ts=4: