summaryrefslogtreecommitdiffstats
path: root/svl/CppunitTest_svl_urihelper.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /svl/CppunitTest_svl_urihelper.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'svl/CppunitTest_svl_urihelper.mk')
-rw-r--r--svl/CppunitTest_svl_urihelper.mk41
1 files changed, 41 insertions, 0 deletions
diff --git a/svl/CppunitTest_svl_urihelper.mk b/svl/CppunitTest_svl_urihelper.mk
new file mode 100644
index 000000000..42b740b7f
--- /dev/null
+++ b/svl/CppunitTest_svl_urihelper.mk
@@ -0,0 +1,41 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,svl_urihelper))
+
+$(eval $(call gb_CppunitTest_use_external,svl_urihelper,boost_headers))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,svl_urihelper))
+
+$(eval $(call gb_CppunitTest_use_components,svl_urihelper, \
+ ucb/source/core/ucb1 \
+ ucb/source/ucp/file/ucpfile1 \
+))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,svl_urihelper, \
+svl/qa/unit/test_URIHelper \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,svl_urihelper, \
+ cppu \
+ cppuhelper \
+ i18nlangtag \
+ sal \
+ svl \
+ tl \
+ utl \
+))
+
+$(eval $(call gb_CppunitTest_use_ure,svl_urihelper))
+
+$(eval $(call gb_CppunitTest_use_components,svl_urihelper,\
+ i18npool/util/i18npool \
+))
+
+# vim: set noet sw=4 ts=4: