summaryrefslogtreecommitdiffstats
path: root/test/Library_test.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /test/Library_test.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test/Library_test.mk')
-rw-r--r--test/Library_test.mk58
1 files changed, 58 insertions, 0 deletions
diff --git a/test/Library_test.mk b/test/Library_test.mk
new file mode 100644
index 000000000..4be059857
--- /dev/null
+++ b/test/Library_test.mk
@@ -0,0 +1,58 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,test))
+
+$(eval $(call gb_Library_set_include,test,\
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_Library_add_defs,test,\
+ -DOOO_DLLIMPLEMENTATION_TEST \
+))
+
+$(eval $(call gb_Library_use_sdk_api,test))
+
+$(eval $(call gb_Library_use_externals,test,\
+ boost_headers \
+ cppunit \
+ libxml2 \
+ valgrind \
+))
+
+$(eval $(call gb_Library_use_libraries,test,\
+ basegfx \
+ comphelper \
+ cppu \
+ cppuhelper \
+ i18nlangtag \
+ sal \
+ svt \
+ test-setupvcl \
+ tl \
+ utl \
+ unotest \
+ vcl \
+ drawinglayer \
+))
+
+$(eval $(call gb_Library_add_exception_objects,test,\
+ test/source/bootstrapfixture \
+ test/source/diff/diff \
+ test/source/callgrind \
+ test/source/xmltesttools \
+ test/source/htmltesttools \
+ test/source/screenshot_test \
+ test/source/unoapi_property_testers \
+ test/source/helper/form \
+ test/source/helper/shape \
+ test/source/helper/transferable \
+))
+
+# vim: set noet sw=4 ts=4: