summaryrefslogtreecommitdiffstats
path: root/tools/CppunitTest_tools_test.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /tools/CppunitTest_tools_test.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tools/CppunitTest_tools_test.mk')
-rw-r--r--tools/CppunitTest_tools_test.mk59
1 files changed, 59 insertions, 0 deletions
diff --git a/tools/CppunitTest_tools_test.mk b/tools/CppunitTest_tools_test.mk
new file mode 100644
index 000000000..5672be533
--- /dev/null
+++ b/tools/CppunitTest_tools_test.mk
@@ -0,0 +1,59 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#*************************************************************************
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#*************************************************************************
+
+$(eval $(call gb_CppunitTest_CppunitTest,tools_test))
+
+$(eval $(call gb_CppunitTest_use_external,tools_test,boost_headers))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,tools_test, \
+ tools/qa/cppunit/test_bigint \
+ tools/qa/cppunit/test_date \
+ tools/qa/cppunit/test_time \
+ tools/qa/cppunit/test_fract \
+ tools/qa/cppunit/test_inetmime \
+ tools/qa/cppunit/test_pathutils \
+ tools/qa/cppunit/test_reversemap \
+ tools/qa/cppunit/test_stream \
+ tools/qa/cppunit/test_urlobj \
+ tools/qa/cppunit/test_color \
+ tools/qa/cppunit/test_rectangle \
+ tools/qa/cppunit/test_minmax \
+ tools/qa/cppunit/test_100mm2twips \
+ tools/qa/cppunit/test_fround \
+ tools/qa/cppunit/test_xmlwalker \
+ tools/qa/cppunit/test_GenericTypeSerializer \
+ tools/qa/cppunit/test_cpuid \
+))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,tools_test))
+
+$(eval $(call gb_CppunitTest_use_libraries,tools_test, \
+ basegfx \
+ sal \
+ tl \
+ test \
+ unotest \
+))
+
+$(eval $(call gb_CppunitTest_use_static_libraries,tools_test, \
+ ooopathutils \
+))
+
+$(eval $(call gb_CppunitTest_set_include,tools_test,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/tools/inc \
+))
+
+$(eval $(call gb_Library_use_externals,tools_test,\
+ libxml2 \
+))
+
+# vim: set noet sw=4 ts=4: