summaryrefslogtreecommitdiffstats
path: root/ucb/CppunitTest_ucb_webdav_res_access.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /ucb/CppunitTest_ucb_webdav_res_access.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'ucb/CppunitTest_ucb_webdav_res_access.mk')
-rw-r--r--ucb/CppunitTest_ucb_webdav_res_access.mk56
1 files changed, 56 insertions, 0 deletions
diff --git a/ucb/CppunitTest_ucb_webdav_res_access.mk b/ucb/CppunitTest_ucb_webdav_res_access.mk
new file mode 100644
index 000000000..fa0669987
--- /dev/null
+++ b/ucb/CppunitTest_ucb_webdav_res_access.mk
@@ -0,0 +1,56 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#*************************************************************************
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#*************************************************************************
+
+$(eval $(call gb_CppunitTest_CppunitTest,ucb_webdav_res_access))
+
+$(eval $(call gb_CppunitTest_use_api,ucb_webdav_res_access, \
+ offapi \
+ udkapi \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,ucb_webdav_res_access, \
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ salhelper \
+ test \
+ ucbhelper \
+ tl \
+))
+
+$(eval $(call gb_CppunitTest_use_library_objects,ucb_webdav_res_access, \
+ ucpdav1 \
+))
+
+$(eval $(call gb_CppunitTest_use_externals,ucb_webdav_res_access,\
+ boost_headers \
+ libxml2 \
+ neon \
+ openssl \
+))
+
+$(eval $(call gb_CppunitTest_use_custom_headers,ucb_webdav_res_access,\
+ officecfg/registry \
+))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,ucb_webdav_res_access, \
+ ucb/qa/cppunit/webdav/webdav_resource_access \
+))
+
+$(eval $(call gb_CppunitTest_set_include,ucb_webdav_res_access,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/ucb/source/ucp/webdav-neon \
+))
+
+$(eval $(call gb_CppunitTest_use_static_libraries,ucb_webdav_res_access))
+
+# vim: set noet sw=4 ts=4: