summaryrefslogtreecommitdiffstats
path: root/unoidl/Executable_unoidl-write.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /unoidl/Executable_unoidl-write.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'unoidl/Executable_unoidl-write.mk')
-rw-r--r--unoidl/Executable_unoidl-write.mk28
1 files changed, 28 insertions, 0 deletions
diff --git a/unoidl/Executable_unoidl-write.mk b/unoidl/Executable_unoidl-write.mk
new file mode 100644
index 000000000..3ba2d9655
--- /dev/null
+++ b/unoidl/Executable_unoidl-write.mk
@@ -0,0 +1,28 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,unoidl-write))
+
+$(eval $(call gb_Executable_add_exception_objects,unoidl-write, \
+ unoidl/source/unoidl-write \
+))
+
+$(eval $(call gb_Executable_use_libraries,unoidl-write, \
+ unoidl \
+ $(if $(filter TRUE,$(DISABLE_DYNLOADING)),reg) \
+ $(if $(filter TRUE,$(DISABLE_DYNLOADING)),store) \
+ salhelper \
+ sal \
+))
+
+ifeq ($(DISABLE_DYNLOADING),TRUE)
+$(eval $(call gb_Executable_use_external,unoidl-write,dtoa))
+endif
+
+# vim: set noet sw=4 ts=4: