summaryrefslogtreecommitdiffstats
path: root/unotools/CppunitTest_unotools_fontdefs.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /unotools/CppunitTest_unotools_fontdefs.mk
parentInitial commit. (diff)
downloadlibreoffice-1ad18e38974bb28c3d98d0be8f7d8c18fc56de29.tar.xz
libreoffice-1ad18e38974bb28c3d98d0be8f7d8c18fc56de29.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'unotools/CppunitTest_unotools_fontdefs.mk')
-rw-r--r--unotools/CppunitTest_unotools_fontdefs.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/unotools/CppunitTest_unotools_fontdefs.mk b/unotools/CppunitTest_unotools_fontdefs.mk
new file mode 100644
index 000000000..5eada2084
--- /dev/null
+++ b/unotools/CppunitTest_unotools_fontdefs.mk
@@ -0,0 +1,30 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,unotools_fontdefs))
+
+$(eval $(call gb_CppunitTest_use_external,unotools_fontdefs,boost_headers))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,unotools_fontdefs))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,unotools_fontdefs, \
+ unotools/qa/unit/testGetEnglishSearchName \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,unotools_fontdefs, \
+ comphelper \
+ cppu \
+ cppuhelper \
+ tl \
+ sal \
+ svt \
+ utl \
+))
+
+# vim: set noet sw=4 ts=4: