summaryrefslogtreecommitdiffstats
path: root/writerperfect/Library_wpftdraw.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /writerperfect/Library_wpftdraw.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--writerperfect/Library_wpftdraw.mk85
1 files changed, 85 insertions, 0 deletions
diff --git a/writerperfect/Library_wpftdraw.mk b/writerperfect/Library_wpftdraw.mk
new file mode 100644
index 000000000..54ad1beb8
--- /dev/null
+++ b/writerperfect/Library_wpftdraw.mk
@@ -0,0 +1,85 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+$(eval $(call gb_Library_Library,wpftdraw))
+
+$(eval $(call gb_Library_set_include,wpftdraw,\
+ -I$(SRCDIR)/writerperfect/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_Library_set_componentfile,wpftdraw,writerperfect/source/draw/wpftdraw))
+
+$(eval $(call gb_Library_use_sdk_api,wpftdraw))
+
+$(eval $(call gb_Library_use_common_precompiled_header,wpftdraw))
+
+$(eval $(call gb_Library_use_libraries,wpftdraw,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ sot \
+ svx \
+ tl \
+ utl \
+ vcl \
+ writerperfect \
+ xo \
+))
+
+$(eval $(call gb_Library_use_externals,wpftdraw,\
+ boost_headers \
+ cdr \
+ freehand \
+ mspub \
+ mwaw \
+ odfgen \
+ zmf \
+ libpng \
+ pagemaker \
+ qxp \
+ revenge \
+ staroffice \
+ visio \
+ wpg \
+ wpd \
+ zlib \
+ lcms2 \
+ libxml2 \
+ icu_headers \
+ icui18n \
+ icuuc \
+))
+
+$(eval $(call gb_Library_add_exception_objects,wpftdraw,\
+ writerperfect/source/draw/CDRImportFilter \
+ writerperfect/source/draw/CMXImportFilter \
+ writerperfect/source/draw/FreehandImportFilter \
+ writerperfect/source/draw/MSPUBImportFilter \
+ writerperfect/source/draw/MWAWDrawImportFilter \
+ writerperfect/source/draw/PageMakerImportFilter \
+ writerperfect/source/draw/QXPImportFilter \
+ writerperfect/source/draw/StarOfficeDrawImportFilter \
+ writerperfect/source/draw/VisioImportFilter \
+ writerperfect/source/draw/WPGImportFilter \
+ writerperfect/source/draw/ZMFImportFilter \
+))
+
+# vim: set noet sw=4 ts=4: