summaryrefslogtreecommitdiffstats
path: root/xmlsecurity/Executable_pdfverify.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /xmlsecurity/Executable_pdfverify.mk
parentInitial commit. (diff)
downloadlibreoffice-upstream/1%7.0.4.tar.xz
libreoffice-upstream/1%7.0.4.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'xmlsecurity/Executable_pdfverify.mk')
-rw-r--r--xmlsecurity/Executable_pdfverify.mk35
1 files changed, 35 insertions, 0 deletions
diff --git a/xmlsecurity/Executable_pdfverify.mk b/xmlsecurity/Executable_pdfverify.mk
new file mode 100644
index 000000000..ed8e9559f
--- /dev/null
+++ b/xmlsecurity/Executable_pdfverify.mk
@@ -0,0 +1,35 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,pdfverify))
+
+$(eval $(call gb_Executable_use_sdk_api,pdfverify))
+
+$(eval $(call gb_Executable_use_external,pdfverify,boost_headers))
+
+$(eval $(call gb_Executable_set_include,pdfverify,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/xmlsecurity/inc \
+))
+
+$(eval $(call gb_Executable_use_libraries,pdfverify,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ tl \
+ vcl \
+ xmlsecurity \
+))
+
+$(eval $(call gb_Executable_add_exception_objects,pdfverify,\
+ xmlsecurity/workben/pdfverify \
+))
+
+# vim:set noet sw=4 ts=4: