summaryrefslogtreecommitdiffstats
path: root/xmlsecurity/Module_xmlsecurity.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /xmlsecurity/Module_xmlsecurity.mk
parentInitial commit. (diff)
downloadlibreoffice-upstream/1%7.0.4.tar.xz
libreoffice-upstream/1%7.0.4.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'xmlsecurity/Module_xmlsecurity.mk')
-rw-r--r--xmlsecurity/Module_xmlsecurity.mk49
1 files changed, 49 insertions, 0 deletions
diff --git a/xmlsecurity/Module_xmlsecurity.mk b/xmlsecurity/Module_xmlsecurity.mk
new file mode 100644
index 000000000..1ce7364d4
--- /dev/null
+++ b/xmlsecurity/Module_xmlsecurity.mk
@@ -0,0 +1,49 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,xmlsecurity))
+
+ifeq ($(ENABLE_NSS),TRUE)
+
+$(eval $(call gb_Module_add_targets,xmlsecurity,\
+ Library_xmlsecurity \
+ Library_xsec_xmlsec \
+ UIConfig_xmlsec \
+))
+
+$(eval $(call gb_Module_add_slowcheck_targets,xmlsecurity,\
+ CppunitTest_xmlsecurity_signing \
+ CppunitTest_xmlsecurity_pdfsigning \
+))
+
+$(eval $(call gb_Module_add_l10n_targets,xmlsecurity,\
+ AllLangMoTarget_xsc \
+))
+
+# failing
+#$(eval $(call gb_Module_add_check_targets,xmlsecurity,\
+ CppunitTest_qa_certext \
+))
+
+# screenshots
+$(eval $(call gb_Module_add_screenshot_targets,xmlsecurity,\
+ CppunitTest_xmlsecurity_dialogs_test \
+))
+
+ifneq (,$(filter DESKTOP,$(BUILD_TYPE)))
+
+$(eval $(call gb_Module_add_targets,xmlsecurity,\
+ Executable_pdfverify \
+))
+
+endif
+
+endif
+
+# vim: set noet sw=4 ts=4: