summaryrefslogtreecommitdiffstats
path: root/RepositoryModule_build.mk
diff options
context:
space:
mode:
Diffstat (limited to 'RepositoryModule_build.mk')
-rw-r--r--RepositoryModule_build.mk61
1 files changed, 61 insertions, 0 deletions
diff --git a/RepositoryModule_build.mk b/RepositoryModule_build.mk
new file mode 100644
index 000000000..9537ccd1d
--- /dev/null
+++ b/RepositoryModule_build.mk
@@ -0,0 +1,61 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,cross_toolset))
+
+$(eval $(call gb_Module_add_moduledirs,cross_toolset,\
+ basegfx \
+ binaryurp \
+ bridges \
+ cli_ure \
+ codemaker \
+ comphelper \
+ cppu \
+ cppuhelper \
+ external \
+ i18nlangtag \
+ i18nutil \
+ i18npool \
+ instsetoo_native \
+ idl \
+ io \
+ javaunohelper \
+ jurt \
+ jvmaccess \
+ jvmfwk \
+ l10ntools \
+ o3tl \
+ offapi \
+ officecfg \
+ oovbaapi \
+ registry \
+ remotebridges \
+ ridljar \
+ sal \
+ salhelper \
+ sax \
+ setup_native \
+ shell \
+ solenv \
+ soltools \
+ stoc \
+ store \
+ tools \
+ ucbhelper \
+ udkapi \
+ unoidl \
+ unoil \
+ unotest \
+ unotools \
+ ure \
+ xmlreader \
+ $(call gb_Helper_optional,QADEVOOO,qadevOOo) \
+))
+
+# vim: set shiftwidth=4 tabstop=4 noexpandtab: