summaryrefslogtreecommitdiffstats
path: root/cpputools/Module_cpputools.mk
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--cpputools/Module_cpputools.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/cpputools/Module_cpputools.mk b/cpputools/Module_cpputools.mk
new file mode 100644
index 000000000..5807e3c81
--- /dev/null
+++ b/cpputools/Module_cpputools.mk
@@ -0,0 +1,24 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,cpputools))
+
+ifneq (,$(filter DESKTOP,$(BUILD_TYPE)))
+
+$(eval $(call gb_Module_add_targets,cpputools,\
+ Executable_sp2bv \
+))
+
+$(eval $(call gb_Module_add_targets,cpputools,\
+ Executable_uno \
+))
+
+endif
+
+# vim:set noet sw=4 ts=4: