summaryrefslogtreecommitdiffstats
path: root/external/apache-commons
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--external/apache-commons/ExternalPackage_apache_commons_logging.mk16
-rw-r--r--external/apache-commons/ExternalProject_apache_commons_logging.mk31
-rw-r--r--external/apache-commons/Makefile7
-rw-r--r--external/apache-commons/Module_apache-commons.mk18
-rw-r--r--external/apache-commons/README1
-rw-r--r--external/apache-commons/UnpackedTarball_apache_commons_logging.mk22
-rw-r--r--external/apache-commons/patches/logging.patch46
7 files changed, 141 insertions, 0 deletions
diff --git a/external/apache-commons/ExternalPackage_apache_commons_logging.mk b/external/apache-commons/ExternalPackage_apache_commons_logging.mk
new file mode 100644
index 000000000..2bff13b93
--- /dev/null
+++ b/external/apache-commons/ExternalPackage_apache_commons_logging.mk
@@ -0,0 +1,16 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_ExternalPackage_ExternalPackage,apache_commons_logging,apache_commons_logging))
+
+$(eval $(call gb_ExternalPackage_use_external_project,apache_commons_logging,apache_commons_logging))
+
+$(eval $(call gb_ExternalPackage_add_file,apache_commons_logging,$(LIBO_SHARE_JAVA_FOLDER)/commons-logging-$(COMMONS_LOGGING_VERSION).jar,target/commons-logging-$(COMMONS_LOGGING_VERSION).jar))
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/apache-commons/ExternalProject_apache_commons_logging.mk b/external/apache-commons/ExternalProject_apache_commons_logging.mk
new file mode 100644
index 000000000..640810d9c
--- /dev/null
+++ b/external/apache-commons/ExternalProject_apache_commons_logging.mk
@@ -0,0 +1,31 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_ExternalProject_ExternalProject,apache_commons_logging))
+
+$(eval $(call gb_ExternalProject_register_targets,apache_commons_logging,\
+ build \
+))
+
+$(call gb_ExternalProject_get_state_target,apache_commons_logging,build) :
+ $(call gb_Trace_StartRange,apache_commons_logging,EXTERNAL)
+ $(call gb_ExternalProject_run,build,\
+ ANT_OPTS="$$ANT_OPTS -Dfile.encoding=ISO-8859-1" \
+ $(ICECREAM_RUN) "$(ANT)" \
+ $(if $(verbose),-v,-q) \
+ -f build.xml \
+ -Dbuild.label="build-$(LIBO_VERSION_MAJOR).$(LIBO_VERSION_MINOR).$(LIBO_VERSION_MICRO).$(LIBO_VERSION_PATCH)" \
+ -Dant.build.javac.source=$(JAVA_SOURCE_VER) \
+ -Dant.build.javac.target=$(JAVA_TARGET_VER) \
+ $(if $(debug),-Dcompile.debug="true",-Dcompile.debug="false") \
+ compile build-jar \
+ )
+ $(call gb_Trace_EndRange,apache_commons_logging,EXTERNAL)
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/apache-commons/Makefile b/external/apache-commons/Makefile
new file mode 100644
index 000000000..e4968cf85
--- /dev/null
+++ b/external/apache-commons/Makefile
@@ -0,0 +1,7 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+
+module_directory:=$(dir $(realpath $(firstword $(MAKEFILE_LIST))))
+
+include $(module_directory)/../../solenv/gbuild/partial_build.mk
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/apache-commons/Module_apache-commons.mk b/external/apache-commons/Module_apache-commons.mk
new file mode 100644
index 000000000..45aabe229
--- /dev/null
+++ b/external/apache-commons/Module_apache-commons.mk
@@ -0,0 +1,18 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,apache-commons))
+
+$(eval $(call gb_Module_add_targets,apache-commons,\
+ ExternalPackage_apache_commons_logging \
+ ExternalProject_apache_commons_logging \
+ UnpackedTarball_apache_commons_logging \
+))
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/apache-commons/README b/external/apache-commons/README
new file mode 100644
index 000000000..18944aca4
--- /dev/null
+++ b/external/apache-commons/README
@@ -0,0 +1 @@
+Java library; used for logging in Extensions, from [http://commons.apache.org/]
diff --git a/external/apache-commons/UnpackedTarball_apache_commons_logging.mk b/external/apache-commons/UnpackedTarball_apache_commons_logging.mk
new file mode 100644
index 000000000..1d5ad3dc2
--- /dev/null
+++ b/external/apache-commons/UnpackedTarball_apache_commons_logging.mk
@@ -0,0 +1,22 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_UnpackedTarball_UnpackedTarball,apache_commons_logging))
+
+$(eval $(call gb_UnpackedTarball_set_tarball,apache_commons_logging,$(APACHE_COMMONS_LOGGING_TARBALL),,apache-commons))
+
+$(eval $(call gb_UnpackedTarball_fix_end_of_line,apache_commons_logging,\
+ build.xml \
+))
+
+$(eval $(call gb_UnpackedTarball_add_patches,apache_commons_logging,\
+ external/apache-commons/patches/logging.patch \
+))
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/apache-commons/patches/logging.patch b/external/apache-commons/patches/logging.patch
new file mode 100644
index 000000000..c225e5a30
--- /dev/null
+++ b/external/apache-commons/patches/logging.patch
@@ -0,0 +1,46 @@
+--- misc/commons-logging-1.1.1-src/build.xml 2007-11-22 00:27:52.000000000 +0100
++++ misc/build/commons-logging-1.1.1-src/build.xml 2008-06-24 14:23:56.316301736 +0200
+@@ -129,12 +129,6 @@
+
+ <!-- ========== Compiler Defaults ========================================= -->
+
+- <!-- Version of java class files to generate. -->
+- <property name="target.version" value="1.2"/>
+-
+- <!-- Version of java source to accept -->
+- <property name="source.version" value="1.2"/>
+-
+ <!-- Should Java compilations set the 'debug' compiler option? -->
+ <property name="compile.debug" value="true"/>
+
+@@ -283,6 +277,10 @@
+ classpathref="compile.classpath"
+ classname="org.apache.avalon.framework.logger.Logger"/>
+
++ <available property="servlet-api.present"
++ classpathref="compile.classpath"
++ classname="javax.servlet.ServletContextListener"/>
++
+ <available file="${log4j12.jar}" property="log4j12.present"/>
+ <available file="${log4j13.jar}" property="log4j13.present"/>
+ <available file="${build.home}/docs" property="maven.generated.docs.present"/>
+@@ -362,8 +360,8 @@
+ debug="${compile.debug}"
+ deprecation="${compile.deprecation}"
+ optimize="${compile.optimize}"
+- source="${source.version}"
+- target="${target.version}">
++ source="${ant.build.javac.source}"
++ target="${ant.build.javac.target}">
+
+ <classpath refid="compile.classpath"/>
+
+@@ -373,6 +371,8 @@
+ unless="logkit.present"/>
+ <exclude name="org/apache/commons/logging/impl/AvalonLogger.java"
+ unless="avalon-framework.present"/>
++ <exclude name="org/apache/commons/logging/impl/ServletContextCleaner.java"
++ unless="servlet-api.present"/>
+ </javac>
+ </target>
+