summaryrefslogtreecommitdiffstats
path: root/external/python3/python-3.3.0-clang.patch.1
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--external/python3/python-3.3.0-clang.patch.113
1 files changed, 13 insertions, 0 deletions
diff --git a/external/python3/python-3.3.0-clang.patch.1 b/external/python3/python-3.3.0-clang.patch.1
new file mode 100644
index 000000000..9001110fb
--- /dev/null
+++ b/external/python3/python-3.3.0-clang.patch.1
@@ -0,0 +1,13 @@
+-*- Mode: diff -*-
+
+--- python3/setup.py
++++ python3/setup.py
+@@ -436,7 +436,7 @@
+ if ret >> 8 == 0:
+ with open(tmpfile) as fp:
+ for line in fp.readlines():
+- if line.startswith("gcc version"):
++ if line.startswith("gcc version") or line.startswith("clang -cc1 version"):
+ is_gcc = True
+ elif line.startswith("#include <...>"):
+ in_incdirs = True