summaryrefslogtreecommitdiffstats
path: root/external/qrcodegen
diff options
context:
space:
mode:
Diffstat (limited to 'external/qrcodegen')
-rw-r--r--external/qrcodegen/Makefile7
-rw-r--r--external/qrcodegen/Module_qrcodegen.mk24
-rw-r--r--external/qrcodegen/README3
-rw-r--r--external/qrcodegen/StaticLibrary_qrcodegen.mk26
-rw-r--r--external/qrcodegen/UnpackedTarball_qrcodegen.mk19
5 files changed, 79 insertions, 0 deletions
diff --git a/external/qrcodegen/Makefile b/external/qrcodegen/Makefile
new file mode 100644
index 000000000..e4968cf85
--- /dev/null
+++ b/external/qrcodegen/Makefile
@@ -0,0 +1,7 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+
+module_directory:=$(dir $(realpath $(firstword $(MAKEFILE_LIST))))
+
+include $(module_directory)/../../solenv/gbuild/partial_build.mk
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/qrcodegen/Module_qrcodegen.mk b/external/qrcodegen/Module_qrcodegen.mk
new file mode 100644
index 000000000..09c771d0d
--- /dev/null
+++ b/external/qrcodegen/Module_qrcodegen.mk
@@ -0,0 +1,24 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,qrcodegen))
+
+$(eval $(call gb_Module_add_targets,qrcodegen,\
+ UnpackedTarball_qrcodegen \
+))
+
+ifeq ($(ENABLE_QRCODEGEN),TRUE)
+
+$(eval $(call gb_Module_add_targets,qrcodegen,\
+ StaticLibrary_qrcodegen \
+))
+
+endif
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/qrcodegen/README b/external/qrcodegen/README
new file mode 100644
index 000000000..d6f19abdc
--- /dev/null
+++ b/external/qrcodegen/README
@@ -0,0 +1,3 @@
+QR code generating library, available from [https://github.com/nayuki/QR-Code-generator/tree/master/cpp].
+
+qrcodegenerator to make the QR code out of a link or text in libreoffice.
diff --git a/external/qrcodegen/StaticLibrary_qrcodegen.mk b/external/qrcodegen/StaticLibrary_qrcodegen.mk
new file mode 100644
index 000000000..d4b21673b
--- /dev/null
+++ b/external/qrcodegen/StaticLibrary_qrcodegen.mk
@@ -0,0 +1,26 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_StaticLibrary_StaticLibrary,qrcodegen))
+
+$(eval $(call gb_StaticLibrary_use_unpacked,qrcodegen,qrcodegen))
+
+$(eval $(call gb_StaticLibrary_set_generated_cxx_suffix,qrcodegen,cpp))
+
+$(eval $(call gb_StaticLibrary_use_external,qrcodegen,icu_headers))
+
+$(eval $(call gb_StaticLibrary_set_warnings_disabled,qrcodegen))
+
+$(eval $(call gb_StaticLibrary_add_generated_exception_objects,qrcodegen,\
+ UnpackedTarball/qrcodegen/cpp/BitBuffer \
+ UnpackedTarball/qrcodegen/cpp/QrCode \
+ UnpackedTarball/qrcodegen/cpp/QrSegment \
+))
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/qrcodegen/UnpackedTarball_qrcodegen.mk b/external/qrcodegen/UnpackedTarball_qrcodegen.mk
new file mode 100644
index 000000000..1ddbc5bc5
--- /dev/null
+++ b/external/qrcodegen/UnpackedTarball_qrcodegen.mk
@@ -0,0 +1,19 @@
+#-*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_UnpackedTarball_UnpackedTarball,qrcodegen))
+
+$(eval $(call gb_UnpackedTarball_set_tarball,qrcodegen,$(QRCODEGEN_TARBALL)))
+
+$(eval $(call gb_UnpackedTarball_set_patchlevel,qrcodegen,1))
+
+$(eval $(call gb_UnpackedTarball_add_patches,qrcodegen, \
+))
+
+# vim: set noet sw=4 ts=4: