summaryrefslogtreecommitdiffstats
path: root/odk/Library_unowinreg.mk
diff options
context:
space:
mode:
Diffstat (limited to 'odk/Library_unowinreg.mk')
-rw-r--r--odk/Library_unowinreg.mk36
1 files changed, 36 insertions, 0 deletions
diff --git a/odk/Library_unowinreg.mk b/odk/Library_unowinreg.mk
new file mode 100644
index 000000000..a514168cd
--- /dev/null
+++ b/odk/Library_unowinreg.mk
@@ -0,0 +1,36 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,unowinreg))
+
+ifeq ($(COM),GCC)
+$(eval $(call gb_Library_add_libs,unowinreg,\
+ -lstdc++ \
+ -lgcc_eh \
+ -lgcc \
+ -lmingw32 \
+ -lmoldname \
+ -lmsvcrt \
+))
+else
+$(eval $(call gb_Library_add_ldflags,unowinreg,\
+ /MANIFEST:NO \
+))
+endif
+
+$(eval $(call gb_Library_add_exception_objects,unowinreg,\
+ odk/source/unowinreg/win/unowinreg \
+))
+
+$(eval $(call gb_Library_use_system_win32_libs,unowinreg,\
+ kernel32 \
+ advapi32 \
+))
+
+# vim: set noet sw=4 ts=4: