summaryrefslogtreecommitdiffstats
path: root/sal/Executable_cppunittester.mk
diff options
context:
space:
mode:
Diffstat (limited to 'sal/Executable_cppunittester.mk')
-rw-r--r--sal/Executable_cppunittester.mk39
1 files changed, 39 insertions, 0 deletions
diff --git a/sal/Executable_cppunittester.mk b/sal/Executable_cppunittester.mk
new file mode 100644
index 000000000..3b9016783
--- /dev/null
+++ b/sal/Executable_cppunittester.mk
@@ -0,0 +1,39 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,cppunittester))
+
+$(eval $(call gb_Executable_set_include,cppunittester,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/sal/inc \
+))
+
+$(eval $(call gb_Executable_use_libraries,cppunittester,\
+ sal \
+))
+
+$(eval $(call gb_Executable_use_externals,cppunittester,\
+ boost_headers \
+ cppunit \
+))
+
+$(eval $(call gb_Executable_add_exception_objects,cppunittester,\
+ sal/cppunittester/cppunittester \
+))
+
+ifeq ($(COM),MSC)
+
+$(eval $(call gb_Executable_add_ldflags,cppunittester,\
+ /STACK:10000000 \
+))
+
+endif
+
+# vim: set noet sw=4 ts=4: