summaryrefslogtreecommitdiffstats
path: root/shell/Library_desktopbe.mk
diff options
context:
space:
mode:
Diffstat (limited to 'shell/Library_desktopbe.mk')
-rw-r--r--shell/Library_desktopbe.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/shell/Library_desktopbe.mk b/shell/Library_desktopbe.mk
new file mode 100644
index 000000000..e70f7c95c
--- /dev/null
+++ b/shell/Library_desktopbe.mk
@@ -0,0 +1,30 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,desktopbe1))
+
+$(eval $(call gb_Library_use_external,desktopbe1,boost_headers))
+
+$(eval $(call gb_Library_use_sdk_api,desktopbe1))
+
+$(eval $(call gb_Library_use_libraries,desktopbe1,\
+ cppu \
+ cppuhelper \
+ sal \
+ tl \
+ vcl \
+))
+
+$(eval $(call gb_Library_set_componentfile,desktopbe1,shell/source/backends/desktopbe/desktopbe1))
+
+$(eval $(call gb_Library_add_exception_objects,desktopbe1,\
+ shell/source/backends/desktopbe/desktopbackend \
+))
+
+# vim: set shiftwidth=4 tabstop=4 noexpandtab: