summaryrefslogtreecommitdiffstats
path: root/arch/c6x/boot/dts/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/c6x/boot/dts/Makefile')
-rw-r--r--arch/c6x/boot/dts/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/arch/c6x/boot/dts/Makefile b/arch/c6x/boot/dts/Makefile
new file mode 100644
index 000000000..f438285c3
--- /dev/null
+++ b/arch/c6x/boot/dts/Makefile
@@ -0,0 +1,16 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for device trees
+#
+
+DTC_FLAGS ?= -p 1024
+
+dtb-$(CONFIG_SOC_TMS320C6455) += dsk6455.dtb
+dtb-$(CONFIG_SOC_TMS320C6457) += evmc6457.dtb
+dtb-$(CONFIG_SOC_TMS320C6472) += evmc6472.dtb
+dtb-$(CONFIG_SOC_TMS320C6474) += evmc6474.dtb
+dtb-$(CONFIG_SOC_TMS320C6678) += evmc6678.dtb
+
+ifneq ($(DTB),)
+obj-y += $(DTB).dtb.o
+endif