summaryrefslogtreecommitdiffstats
path: root/arch/nds32/boot/dts/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/nds32/boot/dts/Makefile')
-rw-r--r--arch/nds32/boot/dts/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/arch/nds32/boot/dts/Makefile b/arch/nds32/boot/dts/Makefile
new file mode 100644
index 000000000..f84bd529b
--- /dev/null
+++ b/arch/nds32/boot/dts/Makefile
@@ -0,0 +1,7 @@
+# SPDX-License-Identifier: GPL-2.0-only
+ifneq '$(CONFIG_NDS32_BUILTIN_DTB)' '""'
+BUILTIN_DTB := $(patsubst "%",%,$(CONFIG_NDS32_BUILTIN_DTB)).dtb.o
+else
+BUILTIN_DTB :=
+endif
+obj-$(CONFIG_OF) += $(BUILTIN_DTB)