summaryrefslogtreecommitdiffstats
path: root/arch/x86/realmode/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/x86/realmode/Makefile')
-rw-r--r--arch/x86/realmode/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/arch/x86/realmode/Makefile b/arch/x86/realmode/Makefile
new file mode 100644
index 000000000..6b1f3a4ee
--- /dev/null
+++ b/arch/x86/realmode/Makefile
@@ -0,0 +1,23 @@
+#
+# arch/x86/realmode/Makefile
+#
+# This file is subject to the terms and conditions of the GNU General Public
+# License. See the file "COPYING" in the main directory of this archive
+# for more details.
+#
+#
+
+# Sanitizer runtimes are unavailable and cannot be linked here.
+KASAN_SANITIZE := n
+KCSAN_SANITIZE := n
+OBJECT_FILES_NON_STANDARD := y
+
+subdir- := rm
+
+obj-y += init.o
+obj-y += rmpiggy.o
+
+$(obj)/rmpiggy.o: $(obj)/rm/realmode.bin
+
+$(obj)/rm/realmode.bin: FORCE
+ $(Q)$(MAKE) $(build)=$(obj)/rm $@