summaryrefslogtreecommitdiffstats
path: root/arch/xtensa/boot/dts/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--arch/xtensa/boot/dts/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/arch/xtensa/boot/dts/Makefile b/arch/xtensa/boot/dts/Makefile
new file mode 100644
index 000000000..0b8d00cda
--- /dev/null
+++ b/arch/xtensa/boot/dts/Makefile
@@ -0,0 +1,17 @@
+#
+# arch/xtensa/boot/dts/Makefile
+#
+# This file is subject to the terms and conditions of the GNU General Public
+# License. See the file "COPYING" in the main directory of this archive
+# for more details.
+#
+#
+
+BUILTIN_DTB_SOURCE := $(patsubst "%",%,$(CONFIG_BUILTIN_DTB_SOURCE)).dtb.o
+ifneq ($(CONFIG_BUILTIN_DTB_SOURCE),"")
+obj-$(CONFIG_OF) += $(BUILTIN_DTB_SOURCE)
+endif
+
+# for CONFIG_OF_ALL_DTBS test
+dtstree := $(srctree)/$(src)
+dtb- := $(patsubst $(dtstree)/%.dts,%.dtb, $(wildcard $(dtstree)/*.dts))