summaryrefslogtreecommitdiffstats
path: root/drivers/dma/dw/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/dma/dw/Makefile')
-rw-r--r--drivers/dma/dw/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/drivers/dma/dw/Makefile b/drivers/dma/dw/Makefile
new file mode 100644
index 000000000..a6f358ad8
--- /dev/null
+++ b/drivers/dma/dw/Makefile
@@ -0,0 +1,11 @@
+# SPDX-License-Identifier: GPL-2.0
+obj-$(CONFIG_DW_DMAC_CORE) += dw_dmac_core.o
+dw_dmac_core-y := core.o dw.o idma32.o
+dw_dmac_core-$(CONFIG_ACPI) += acpi.o
+
+obj-$(CONFIG_DW_DMAC) += dw_dmac.o
+dw_dmac-y := platform.o
+dw_dmac-$(CONFIG_OF) += of.o
+
+obj-$(CONFIG_DW_DMAC_PCI) += dw_dmac_pci.o
+dw_dmac_pci-y := pci.o