summaryrefslogtreecommitdiffstats
path: root/drivers/gpu/drm/ttm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/gpu/drm/ttm/Makefile')
-rw-r--r--drivers/gpu/drm/ttm/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/drivers/gpu/drm/ttm/Makefile b/drivers/gpu/drm/ttm/Makefile
new file mode 100644
index 000000000..90c0da88c
--- /dev/null
+++ b/drivers/gpu/drm/ttm/Makefile
@@ -0,0 +1,12 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for the drm device driver. This driver provides support for the
+
+ttm-y := ttm_memory.o ttm_tt.o ttm_bo.o \
+ ttm_bo_util.o ttm_bo_vm.o ttm_module.o \
+ ttm_execbuf_util.o ttm_page_alloc.o ttm_range_manager.o \
+ ttm_resource.o
+ttm-$(CONFIG_AGP) += ttm_agp_backend.o
+ttm-$(CONFIG_DRM_TTM_DMA_PAGE_POOL) += ttm_page_alloc_dma.o
+
+obj-$(CONFIG_DRM_TTM) += ttm.o