summaryrefslogtreecommitdiffstats
path: root/drivers/interconnect/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--drivers/interconnect/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/drivers/interconnect/Makefile b/drivers/interconnect/Makefile
new file mode 100644
index 000000000..d203520b0
--- /dev/null
+++ b/drivers/interconnect/Makefile
@@ -0,0 +1,8 @@
+# SPDX-License-Identifier: GPL-2.0
+
+CFLAGS_core.o := -I$(src)
+icc-core-objs := core.o bulk.o
+
+obj-$(CONFIG_INTERCONNECT) += icc-core.o
+obj-$(CONFIG_INTERCONNECT_IMX) += imx/
+obj-$(CONFIG_INTERCONNECT_QCOM) += qcom/