summaryrefslogtreecommitdiffstats
path: root/kernel/cgroup/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'kernel/cgroup/Makefile')
-rw-r--r--kernel/cgroup/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/kernel/cgroup/Makefile b/kernel/cgroup/Makefile
new file mode 100644
index 000000000..5d7a76bfb
--- /dev/null
+++ b/kernel/cgroup/Makefile
@@ -0,0 +1,8 @@
+# SPDX-License-Identifier: GPL-2.0
+obj-y := cgroup.o rstat.o namespace.o cgroup-v1.o freezer.o
+
+obj-$(CONFIG_CGROUP_FREEZER) += legacy_freezer.o
+obj-$(CONFIG_CGROUP_PIDS) += pids.o
+obj-$(CONFIG_CGROUP_RDMA) += rdma.o
+obj-$(CONFIG_CPUSETS) += cpuset.o
+obj-$(CONFIG_CGROUP_DEBUG) += debug.o