summaryrefslogtreecommitdiffstats
path: root/sound/soc/intel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sound/soc/intel/Makefile')
-rw-r--r--sound/soc/intel/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/sound/soc/intel/Makefile b/sound/soc/intel/Makefile
new file mode 100644
index 000000000..7c5038803
--- /dev/null
+++ b/sound/soc/intel/Makefile
@@ -0,0 +1,12 @@
+# SPDX-License-Identifier: GPL-2.0-only
+# Core support
+obj-$(CONFIG_SND_SOC) += common/
+
+# Platform Support
+obj-$(CONFIG_SND_SST_ATOM_HIFI2_PLATFORM) += atom/
+obj-$(CONFIG_SND_SOC_INTEL_CATPT) += catpt/
+obj-$(CONFIG_SND_SOC_INTEL_SKYLAKE_COMMON) += skylake/
+obj-$(CONFIG_SND_SOC_INTEL_KEEMBAY) += keembay/
+
+# Machine support
+obj-$(CONFIG_SND_SOC) += boards/