summaryrefslogtreecommitdiffstats
path: root/tools/testing/selftests/sysctl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/testing/selftests/sysctl/Makefile')
-rw-r--r--tools/testing/selftests/sysctl/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/tools/testing/selftests/sysctl/Makefile b/tools/testing/selftests/sysctl/Makefile
new file mode 100644
index 000000000..110301f9f
--- /dev/null
+++ b/tools/testing/selftests/sysctl/Makefile
@@ -0,0 +1,13 @@
+# SPDX-License-Identifier: GPL-2.0-only
+# Makefile for sysctl selftests.
+# Expects kernel.sysctl_writes_strict=1.
+
+# No binaries, but make sure arg-less "make" doesn't trigger "run_tests".
+all:
+
+TEST_PROGS := sysctl.sh
+
+include ../lib.mk
+
+# Nothing to clean up.
+clean: