summaryrefslogtreecommitdiffstats
path: root/tools/testing/vsock/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/testing/vsock/Makefile')
-rw-r--r--tools/testing/vsock/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/tools/testing/vsock/Makefile b/tools/testing/vsock/Makefile
new file mode 100644
index 000000000..f8293c691
--- /dev/null
+++ b/tools/testing/vsock/Makefile
@@ -0,0 +1,11 @@
+# SPDX-License-Identifier: GPL-2.0-only
+all: test
+test: vsock_test vsock_diag_test
+vsock_test: vsock_test.o timeout.o control.o util.o
+vsock_diag_test: vsock_diag_test.o timeout.o control.o util.o
+
+CFLAGS += -g -O2 -Werror -Wall -I. -I../../include -I../../../usr/include -Wno-pointer-sign -fno-strict-overflow -fno-strict-aliasing -fno-common -MMD -U_FORTIFY_SOURCE -D_GNU_SOURCE
+.PHONY: all test clean
+clean:
+ ${RM} *.o *.d vsock_test vsock_diag_test
+-include *.d